Bug 1420866 - enable_new_agents in neutron.conf in the Compute(s) seems to have no purpose [NEEDINFO]
Summary: enable_new_agents in neutron.conf in the Compute(s) seems to have no purpose
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 12.0 (Pike)
Assignee: Assaf Muller
QA Contact: Toni Freger
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-09 16:50 UTC by Irina Petrova
Modified: 2020-06-11 13:17 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-15 13:41:22 UTC
Target Upstream Version:
amuller: needinfo? (ipetrova)


Attachments (Terms of Use)

Description Irina Petrova 2017-02-09 16:50:19 UTC
Description of problem:

Setting `enable_new_agents=False` in neutron.conf on the Compute Nodes seems to do nothing (in a non-DVR setup at least). We have no description/documentation on it and it is not clear if this is a bug or a feature, i.e. if we are planning on 'fixing it' and/or if it has already been fixed.

Can we get some clarification on it?

// Case scenario:
~~~~~~~~~~~~~~~~~
We have set `enable_new_agents = False` in neutron.conf. I thought this would only affect neutron agents located on newly added Network nodes. For example, on the L3-agent on the network nodes, forcing no virtual routers to be added on the new network node. But this also has put the admin-state-up on false on the neutron-openvswitch-agent on new compute nodes. Still this seems not to have any affect; there are instances spawned on the compute node and they have working network connectivity.
~~~~~~~~~~~~~~~~~

Version-Release number of selected component (if applicable):
All versions?

Additional Info:
`enable_new_agents=False` in neutron ovs agent on the Controllers:
https://specs.openstack.org/openstack/neutron-specs/specs/liberty/enable-new-agents.html

Comment 1 Assaf Muller 2017-04-28 18:19:34 UTC
The spec explicitly talks only about scheduling (L3, DHCP, LBaaS agents). The OVS agent is out of scope and the behavior is undefined.

It seems like the feature did work for you on the L3 agent, which is great, and the issue is that it set the admin-state-up to False on the OVS agents, but it had no effect?

The request here is to fix it so that the OVS agents would start with admin-state-up equals True when enable_new_agents=False?

Comment 2 Irina Petrova 2017-05-10 15:56:31 UTC
Hi Assaf!

Apologies for the delay (I haven't noticed your update).

~~~
The request here is to fix it so that the OVS agents would start with admin-state-up equals True when enable_new_agents=False?
~~~

No, this was a request for information on what does enable_new_agents=False do for OVS agent (since it's not noted anywhere as far as I can see and if I remember correctly even some of the Neutron guys couldn't tell) and you've just demystified it (Thank you for clearing it up!):

~~~
The spec explicitly talks only about scheduling (L3, DHCP, LBaaS agents). The OVS agent is out of scope and the behavior is undefined.
~~~

However, getting a fix so that OVS agents would start in Admin State TRUE when enable_new_agents=False might be a good idea. :) What we want to achieve here is clarity. I think even slightly extending the neutron.conf description could do (with or without the OVS agent fix; although it's better if OVS agent does *not* change Admin State, because it makes more sense, in my opinion).

From:
~~~
# Agent starts with admin_state_up=False when enable_new_agents=False. In the
# case, user's resources will not be scheduled automatically to the agent until
# admin changes admin_state_up to True. (boolean value)
#enable_new_agents = true
~~~

To (for example, based on your answer):
~~~
# Agent starts with admin_state_up=False when enable_new_agents=False. In the
# case, user's resources will not be scheduled automatically to the agent until
# admin changes admin_state_up to True. (boolean value)
# NOTE: Applicable to L3 agent, DHCP agent, and LBaaS agent. OVS agent is OUT OF 
# THIS SCOPE and its behavior is undefined! 
#enable_new_agents = true
~~~

Your call on what is the best way to bring that clarity in. Other than that we can close this as a NOTABUG.

Comment 3 Assaf Muller 2017-05-15 13:41:22 UTC
Please open a bug upstream so we can make the documentation clearer.


Note You need to log in before you can comment on or make changes to this bug.