Bug 1420876 - Respin RHVH once platform BZ 1431149 is fixed [Emulex lpfc driver]
Summary: Respin RHVH once platform BZ 1431149 is fixed [Emulex lpfc driver]
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 4.0.4
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ovirt-4.1.1-1
: ---
Assignee: Ryan Barry
QA Contact: dguo
URL:
Whiteboard:
Depends On: 1420473 1431149
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-09 17:43 UTC by Gordon Watson
Modified: 2020-09-10 10:12 UTC (History)
10 users (show)

Fixed In Version: redhat-virtualization-host-4.1-20170413.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-10 10:10:31 UTC
oVirt Team: Node
Target Upstream Version:
lsvaty: testing_plan_complete-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2894141 0 None None None 2017-02-09 18:07:28 UTC

Description Gordon Watson 2017-02-09 17:43:50 UTC
Description of problem:

BZ 1418065 describes the problem where, in a RHEV environment, when hosts are upgraded to RHEL 7.3 and VMs access a direct lun configured as virtio-scsi with scsi-passthrough enabled and the lun is accessed via an Emulex FC HBA, the VMs will be paused due to an i/o error. 

However, the problem is not in RHEV/VDSM, but in the Emulex driver. The current resolution to the bug is to increase the 'lpfc_sg_seg_cnt' in 'lpfc.conf'.

Is it possible/feasible that VDSM can manage this configuration ?


 
Version-Release number of selected component (if applicable):

RHEV 3.6
RHV 4.0


How reproducible:

100% with the default 'lpfc_sg_seg_cnt' parameter.


Steps to Reproduce:

Refer to BZ 1418065.


Actual results:


Expected results:


Additional info:

Comment 4 Allon Mureinik 2017-02-23 09:02:01 UTC
Moving to the Node team, ss the discussed solution should come from the platform and node should respin on top of it.

Comment 5 Dan Kenigsberg 2017-02-28 09:06:01 UTC
I hate the idea of owning another platform config file; I hope this can be solved below RHV (in the driver) or above RHV (by a customer deployment script).

https://bugzilla.redhat.com/show_bug.cgi?id=1420473#c34

Comment 6 Marina Kalinin 2017-03-06 13:36:48 UTC
Once we

Comment 9 cshao 2017-04-20 03:27:08 UTC
Test version:
redhat-virtualization-host-4.1-20170417
imgbased-0.9.23-0.1.el7ev.noarch
kernel-3.10.0-514.16.1.el7.x86_64

# rpm -qa| grep qemu-kvm
qemu-kvm-rhev-2.6.0-28.el7_3.9.x86_64
qemu-kvm-tools-rhev-2.6.0-28.el7_3.9.x86_64
qemu-kvm-common-rhev-2.6.0-28.el7_3.9.x86_64

RHVH include the correct qemu-kvm-rhev version which already included the fix for bug 1431149.
So the bug is fixed, change bug status to VERIFIED.

Comment 12 Daniel Gur 2019-08-28 12:57:44 UTC
sync2jira

Comment 13 Daniel Gur 2019-08-28 13:02:19 UTC
sync2jira

Comment 14 Daniel Gur 2019-08-28 13:12:06 UTC
sync2jira

Comment 15 Daniel Gur 2019-08-28 13:16:18 UTC
sync2jira


Note You need to log in before you can comment on or make changes to this bug.