Bug 1420899 - OCP HA node fails @ 10% during satellite registration: "ActiveRecord::RecordInvalid: Validation failed: Name has already been taken"
Summary: OCP HA node fails @ 10% during satellite registration: "ActiveRecord::RecordI...
Keywords:
Status: CLOSED DUPLICATE of bug 1412784
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - OpenShift
Version: 1.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: John Matthews
QA Contact: Sudhir Mallamprabhakara
Derek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-09 19:50 UTC by Landon LaSmith
Modified: 2017-02-10 17:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-10 17:20:19 UTC
Target Upstream Version:


Attachments (Terms of Use)
Ansible Log (83.78 KB, text/plain)
2017-02-09 19:50 UTC, Landon LaSmith
no flags Details
production log (4.17 MB, text/plain)
2017-02-09 19:56 UTC, Landon LaSmith
no flags Details

Description Landon LaSmith 2017-02-09 19:50:41 UTC
Created attachment 1248886 [details]
Ansible Log

Description of problem: During a RHV deployment, ocp-master1 node fails satellite registration during TASK [satellite_registration : Register to Satellite] 

2017-02-09 13:44:13,028 p=3728 u=foreman | fatal: [ocpha-ocp-master1.example.com]: FAILED! => {"changed": false, "cmd": "subscription-manager register --activationkey OpenShift-ocpha-OpenShift --org Default_Organization", "failed": true, "msg": "Task e2dbec57-0657-42b3-9c50-438f1f6afd68: ActiveRecord::RecordInvalid: Validation failed: Name has already been taken", "rc": 70, "stderr": "Task e2dbec57-0657-42b3-9c50-438f1f6afd68: ActiveRecord::RecordInvalid: Validation failed: Name has already been taken\n", "stdout": "", "stdout_lines": []}

QCI Media Version: QCI-1.1-RHEL-7-20170208.t.0

How reproducible: 2nd occurrence

Steps to Reproduce:
1. Install QCI from iso
2. Create and start RHV+OCPHA 
3.

Actual results: During OCPHA install, ocp node satellite registration fails

Expected results: OCP node registration succeeds

Additional info:
RHV Baremetal deployment w/ 1 engine + 3 hypervisors

Comment 1 Landon LaSmith 2017-02-09 19:56:50 UTC
Created attachment 1248887 [details]
production log

Comment 2 Antonin Pagac 2017-02-10 14:10:53 UTC
Hit this with QCI-1.1-RHEL-7-20170209.t.1. The error seems to be intermittent, I have seen it also with one of the older composes.

Comment 3 John Matthews 2017-02-10 16:34:10 UTC
This might be related to https://bugzilla.redhat.com/show_bug.cgi?id=1412784

Comment 4 John Matthews 2017-02-10 17:20:19 UTC

*** This bug has been marked as a duplicate of bug 1412784 ***


Note You need to log in before you can comment on or make changes to this bug.