Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1420965 - youtube-dl cannot find pycrypto, even though it is installed
Summary: youtube-dl cannot find pycrypto, even though it is installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: youtube-dl
Version: 25
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Till Maas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 01:51 UTC by postmodern
Modified: 2018-04-11 12:01 UTC (History)
3 users (show)

Fixed In Version: youtube-dl-2017.02.16-1.fc25 youtube-dl-2017.02.16-1.fc24 youtube-dl-2017.02.16-1.el6 youtube-dl-2017.02.16-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-18 18:21:11 UTC
Type: Bug


Attachments (Terms of Use)

Description postmodern 2017-02-10 01:51:20 UTC
Description of problem: youtube-dl cannot find the pycrypto library, even though the python2-crypto rpm is installed.


Version-Release number of selected component (if applicable): 2017.01.31-1.fc25


How reproducible: certain URLs will cause youtube-dl to load pycrypto

Steps to Reproduce:
1. youtube-dl "https://video.vice.com/en_us/video/meet-the-masterminds-behind-las-new-jerry-maguire-video-store/5881151ed670a17f4b6a9fde?Latest_from_VICE=1"

Actual results:
ERROR: pycrypto not found. Please install it.


Expected results: loads the python2-crypto library.


Additional info:

Comment 1 Matěj Cepl 2017-02-16 19:57:36 UTC
Not sure, what's the problem. Cannot reproduce here (with youtube-dl-2017.02.16-1.fc25.noarch):

$ youtube-dl --proxy=http://somewhereinus 'https://video.vice.com/en_us/video/meet-the-masterminds-behind-las-new-jerry-maguire-video-store/5881151ed670a17f4b6a9fde?Latest_from_VICE=1'
[Vice] meet-the-masterminds-behind-las-new-jerry-maguire-video-store: Downloading webpage
[Vice] 5881151ed670a17f4b6a9fde: Downloading JSON metadata
[uplynk:preplay] 188f9410901e413f94b829d36e1f19fa: Downloading JSON metadata
[uplynk:preplay] 188f9410901e413f94b829d36e1f19fa: Downloading m3u8 information
[uplynk:preplay] 188f9410901e413f94b829d36e1f19fa: Downloading JSON metadata
[hlsnative] Downloading m3u8 manifest
[hlsnative] Total fragments: 132
[download] Destination: Meet the Masterminds Behind LA's New 'Jerry Maguire' Video Store-5881151ed670a17f4b6a9fde.mp4
[download] 100% of 276.53MiB in 11:03
[ffmpeg] Fixing malformated aac bitstream in "Meet the Masterminds Behind LA's New 'Jerry Maguire' Video Store-5881151ed670a17f4b6a9fde.mp4"
$

Comment 2 Fedora Update System 2017-02-16 19:59:09 UTC
youtube-dl-2017.02.16-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-629e058c5e

Comment 3 Fedora Update System 2017-02-16 19:59:21 UTC
youtube-dl-2017.02.16-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-185162e843

Comment 4 Fedora Update System 2017-02-16 19:59:29 UTC
youtube-dl-2017.02.16-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-2759025f5b

Comment 5 Fedora Update System 2017-02-16 19:59:37 UTC
youtube-dl-2017.02.16-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-9aec471979

Comment 6 Till Maas 2017-02-16 21:36:59 UTC
AFAICS the error message is misleading, since it does not seem to depend on whether pycrypto is available but on some other problem maybe:
https://github.com/rg3/youtube-dl/blob/master/youtube_dl/downloader/hls.py#L69

Comment 7 Fedora Update System 2017-02-17 21:18:47 UTC
youtube-dl-2017.02.16-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-9aec471979

Comment 8 Fedora Update System 2017-02-17 21:48:46 UTC
youtube-dl-2017.02.16-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-2759025f5b

Comment 9 Fedora Update System 2017-02-17 22:53:18 UTC
youtube-dl-2017.02.16-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-629e058c5e

Comment 10 Fedora Update System 2017-02-18 00:16:26 UTC
youtube-dl-2017.02.16-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-185162e843

Comment 11 Fedora Update System 2017-02-18 18:21:11 UTC
youtube-dl-2017.02.16-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2017-02-19 22:47:57 UTC
youtube-dl-2017.02.16-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2017-03-05 05:47:34 UTC
youtube-dl-2017.02.16-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2017-03-05 05:48:31 UTC
youtube-dl-2017.02.16-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.