Bug 1420970 - [quick installer]quick installer failed due to a python method failure
Summary: [quick installer]quick installer failed due to a python method failure
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Tim Bielawa
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks: 1421053 1421059 1421061
TreeView+ depends on / blocked
 
Reported: 2017-02-10 02:48 UTC by Wenkai Shi
Modified: 2017-07-24 14:11 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: An ansible release introduced a regression that caused datastructures to fail to serialize when writing them out to a YAML document. Consequence: Users would trigger the regression during the pre-run fact fetching, causing their installation to crash. Fix: Ansible introduced a new YAML serializing system in an update. The old serializing system was replaced with the new one, "AnsibleDumper". Result: The quick installer can run the "Gathering information from hosts" actions now without triggering the error during serializing.
Clone Of:
: 1421053 1421059 1421061 (view as bug list)
Environment:
Last Closed: 2017-04-12 19:01:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0903 0 normal SHIPPED_LIVE OpenShift Container Platform atomic-openshift-utils bug fix and enhancement 2017-04-12 22:45:42 UTC

Description Wenkai Shi 2017-02-10 02:48:42 UTC
Description of problem:
Quick installer get failed in "Gathering information from hosts" step, looks relate to a python method failure.

Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.5.6-1.git.0.5e6099d.el7

How reproducible:
100%

Steps to Reproduce:
1.run quick installer
2.
3.

Actual results:
[root@installer ~]# atomic-openshift-installer install
...
Gathering information from hosts...
 [WARNING]: Failure using method (v2_runner_on_ok) in callback plugin (</usr/lib/python2.7/site-packages/ooinstall/ansible_plugins/facts_callback.CallbackModule object at 0x2903910>): cannot
represent an object: common
There was a problem fetching the required information. Please see /tmp/ansible.log for details.

Expected results:
Installation succeed 

Additional info:
[root@installer ~]# tail /tmp/ansible.log
...
2017-02-10 10:14:24,547 p=14688 u=root |   [WARNING]: Failure using method (v2_runner_on_ok) in callback plugin (</usr/lib/python2.7/site-packages/ooinstall/ansible_plugins/facts_callback.CallbackModule object at 0x2903910>): cannot
represent an object: common

2017-02-10 10:14:24,552 p=14688 u=root |  PLAY RECAP *********************************************************************
2017-02-10 10:14:24,552 p=14688 u=root |  localhost                  : ok=10   changed=0    unreachable=0    failed=0   
2017-02-10 10:14:24,552 p=14688 u=root |  master.example.com : ok=52   changed=3    unreachable=0    failed=0

Comment 7 Wenkai Shi 2017-02-27 06:22:46 UTC
Has been fix in atomic-openshift-utils-3.5.15-1.git.0.8d2a456, will verify it when "Status" change.

Comment 8 Tim Bielawa 2017-02-27 16:35:40 UTC
Fix was merged into master (3.5) in https://github.com/openshift/openshift-ansible/pull/3486

Comment 10 Wenkai Shi 2017-02-28 02:04:58 UTC
Verified with version atomic-openshift-utils-3.5.17-1.git.0.561702e and ansible-2.2.1.0-2, quick installer can pass the "Gathering information from hosts..." step without any error.

Comment 12 errata-xmlrpc 2017-04-12 19:01:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0903


Note You need to log in before you can comment on or make changes to this bug.