Bug 1420988 - virt-manager wont start
Summary: virt-manager wont start
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 04:36 UTC by Kempe
Modified: 2017-05-18 10:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-13 13:01:02 UTC
Type: Bug


Attachments (Terms of Use)

Description Kempe 2017-02-10 04:36:06 UTC
Description of problem:
virt-manager fails to start with ImportError: cannot import name integer_types

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install virt-manager from software center or dnf
2. try to launch virt-manager

Actual results:
File "/usr/share/virt-manager/virt-manager", line 33, in <module>
    from virtinst import util as util
  File "/usr/share/virt-manager/virtinst/__init__.py", line 89, in <module>
    from virtinst.distroinstaller import DistroInstaller
  File "/usr/share/virt-manager/virtinst/distroinstaller.py", line 23, in <module>
    from . import urlfetcher
  File "/usr/share/virt-manager/virtinst/urlfetcher.py", line 34, in <module>
    import requests
  File "/usr/lib/python2.7/site-packages/requests/__init__.py", line 64, in <module>
    from . import utils
  File "/usr/lib/python2.7/site-packages/requests/utils.py", line 26, in <module>
    from .compat import (
ImportError: cannot import name integer_types

Expected results:
virt-manager would start and i could get things done

Additional info:

Comment 1 Cole Robinson 2017-02-10 15:29:56 UTC
Looks like something wrong with python2-requests or one of its deps. Can you do

  sudo yum reinstall python2-requests

If that doesn't work, see if you have another version of requests installed maybe via pip, or provide the output of


  sudo find / -name \*requests\* -type d

Comment 2 Kempe 2017-02-10 17:28:43 UTC
Yeah I did install requests via pip, I have a "requirement" file i run on new installs. after removing that and installing the one from repo everything works fine. (bow)

Comment 3 Jan Kalina 2017-05-18 10:03:17 UTC
Just reproduced on Fedora 25 too - for others: to fix run:

sudo pip install --force-reinstall -I requests


Note You need to log in before you can comment on or make changes to this bug.