This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 142100 - array index out of range
array index out of range
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-07 05:41 EST by David Binderman
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-07 17:33:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Binderman 2004-12-07 05:41:45 EST
Description of problem:

I just tried to compile package parted-1.6.15-5 from 
Redhat Fedora Core 3.

The compiler said

disk_dvh.c(466): warning #175: subscript out of range

The source code is

        vd->vd_name[VDNAMESIZE] = 0;

I agree with the compiler. This code would benefit from re-work to ensure
that non existant data is not accessed.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Andrew Clausen 2004-12-18 06:18:34 EST
I fixed it (I hope ;)  Thanks!

Note You need to log in before you can comment on or make changes to this bug.