Bug 1421014 - Support keystone v3 in cinderclient
Summary: Support keystone v3 in cinderclient
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-cinderclient
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: z3
: 10.0 (Newton)
Assignee: Alan Bishop
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 06:17 UTC by Mohammad Rizwan
Modified: 2020-08-13 08:51 UTC (History)
6 users (show)

Fixed In Version: python-cinderclient-1.9.0-6.el7ost
Doc Type: Bug Fix
Doc Text:
The cinder client did not support keystone v3 properly. Consequently, any attempts to use the keystone v3 API would fail. The problems has been fixed. Now, the cinder client correctly works with keystone v3.
Clone Of:
Environment:
Last Closed: 2017-06-28 15:38:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1546280 0 None None None 2017-02-10 14:12:47 UTC
OpenStack gerrit 404572 0 None None None 2017-02-10 14:13:10 UTC
Red Hat Product Errata RHBA-2017:1591 0 normal SHIPPED_LIVE openstack-cinder bug fix advisory 2017-06-28 19:14:07 UTC

Description Mohammad Rizwan 2017-02-10 06:17:23 UTC
Description of problem:

One of the client is facing similar issue and needs a fix. 
I saw that the issue is been fixed in python-cinderclient[1]. 
Can we have this changes merged in downstream as well?

[1] https://bugs.launchpad.net/python-cinderclient/+bug/1546280

Version-Release number of selected component (if applicable):
- python-cinderclient-1.9.0-4.el7ost.noarch.rpm  
- Red Hat OpenStack Platform - 10(Newton)

Comment 2 Tzach Shefi 2017-03-23 09:15:16 UTC
Verified on:
rpm -qa | grep python-cinder
python-cinderclient-1.9.0-6.el7ost.noarch

#cinder --debug  --os-user-domain-name default --os-project-domain-name default --os-auth-url http://10.0.0.108:5000/v3  create 1

Created a volume as expected.
See #cinder list results at the bottom. 


#cinder --debug  --os-user-domain-name default --os-project-domain-name default --os-auth-url http://10.0.0.108:5000/v3  list

DEBUG:keystoneauth.session:REQ: curl -g -i -X GET http://10.0.0.108:5000/v3 -H "Accept: application/json" -H "User-Agent: cinder keystoneauth1/2.12.3 python-requests/2.10.0 CPython/2.7.5"
DEBUG:keystoneauth.session:RESP: [200] Date: Thu, 23 Mar 2017 09:10:47 GMT Server: Apache Vary: X-Auth-Token,Accept-Encoding x-openstack-request-id: req-250ff49d-3ef7-42b7-bf1f-18b724db9fed Content-Encoding: gzip Content-Length: 192 Content-Type: application/json 
RESP BODY: {"version": {"status": "stable", "updated": "2016-10-06T00:00:00Z", "media-types": [{"base": "application/json", "type": "application/vnd.openstack.identity-v3+json"}], "id": "v3.7", "links": [{"href": "http://10.0.0.108:5000/v3/", "rel": "self"}]}}

skipped some lines here..

DEBUG:keystoneauth.identity.v3.base:Making authentication request to http://10.0.0.108:5000/v3/auth/tokens
DEBUG:keystoneauth.identity.v3.base:{"token": {"is_domain": false, "methods": ["password"], "roles": [{"id": "a031650c8000499ca6fe851b6d46de2b", "name": "admin"}], "expires_at": "2017-03-23T10:10:48.000000Z", "project": {"domain": {"id": "default", "name": "Default"}, "id": "8733dd13c33e48469454b288396ec7c9", "name": "admin"}, "catalog": [{"endpoints": [{"url": "http://172.17.1.15:8774/v2.1", "interface": "admin", "region": "regionOne", 
GET call to volumev2 for http://10.0.0.108:8776/v2/8733dd13c33e48469454b288396ec7c9/volumes/detail used request id req-b8a7ccb5-2e6b-496a-a5fc-01a6fb605914
DEBUG:cinderclient.client:GET call to volumev2 for http://10.0.0.108:8776/v2/8733dd13c33e48469454b288396ec7c9/volumes/detail used request id req-b8a7ccb5-2e6b-496a-a5fc-01a6fb605914
+--------------------------------------+-----------+------+------+-------------+----------+-------------+
| ID                                   | Status    | Name | Size | Volume Type | Bootable | Attached to |
+--------------------------------------+-----------+------+------+-------------+----------+-------------+
| 68b0d87d-1386-483b-980e-a9482b94e9fb | available | -    | 1    | -           | false    |             |
+--------------------------------------+-----------+------+------+-------------+----------+-------------+

Both Cinder python client commands create/list work with keystone v3 endpoint.

Comment 8 errata-xmlrpc 2017-06-28 15:38:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1591


Note You need to log in before you can comment on or make changes to this bug.