Bug 142102 - Remove the tiglusb kernel module
Remove the tiglusb kernel module
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-07 06:03 EST by Michael A. Peters
Modified: 2015-01-04 17:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-10 20:13:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael A. Peters 2004-12-07 06:03:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
The tiglusb kernel module is responsible for connecting a TI graphing
calculator with a Linux computer through the SilverLink USB cable, for
programs like TiLP (which Fedora doesn't ship with anyway, and I don't
think it is even in Extras)

Problem is - I have never gotten the kernel module to work, and there
is a better way - the current version of libticables can link against
libusb - and talk to the SilverLink USB cable without needing a kernel
module, which is (imho) better. And I have gotten it to work that way
- as long as I first rmmod the tiglusb kernel module.

Since the kernel module does not seem to work, and there is a non
kernel way of doing the same thing, it would seem that the kernwl
module isn't needed any longer, and in fact gets in the way of talking
to the device with the modern libraries.

AFAIK no Fedora supported applications use the kernel module, AFAIK
the only apps that use it are TiLP and TiEmu - both of which use
libticables which links againsy libusb if it can, and libusb is
provided by Fedora Core, so is available to those building libticables
on a Fedora Core system. So as far as I can tell, the impact of
removing the tiglusb kernel module is about nil.

Fedora doesn't even by default create the device nodes needed for it
anyway (though MAKEDEV can), and it gets in the way if it loads
automagically (which it does)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. build ticables linked against libusb
2. try to use TiLP with silverlink cable
3. TiLP fails unless you have rmmod tiglusb first
    

Additional info:
Comment 5 Dave Jones 2004-12-10 18:00:38 EST
fixed in cvs. will be in next builds.

Note You need to log in before you can comment on or make changes to this bug.