Bug 142103 - %post fails on readonly-mounted /usr/share
Summary: %post fails on readonly-mounted /usr/share
Status: CLOSED DUPLICATE of bug 122713
Alias: None
Product: Fedora
Classification: Fedora
Component: servletapi5   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gary Benson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 51193
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-07 11:59 UTC by Enrico Scholz
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-03 09:15:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2004-12-07 11:59:37 UTC
Description of problem:

| # rpm -Uvh servletapi5-5.0.18-1jpp_3fc.noarch.rpm servletapi5-javadoc-5.0.18-1jpp_3fc.noarch.rpm
| Preparing...                ########################################### [100%]
|    1:servletapi5-javadoc    ########################################### [ 50%]
| rm: cannot remove `/usr/share/javadoc/servletapi5': Read-only file system
| rm: cannot remove `/usr/share/javadoc/jsp-api': Read-only file system
| ln: creating symbolic link `/usr/share/javadoc/servletapi5/servletapi5-5.0.18' to `servletapi5-5.0.18': Read-only file system
| ln: creating symbolic link `/usr/share/javadoc/jsp-api/jsp-api-5.0.18' to `jsp-api-5.0.18': Read-only file system
| error: %post(servletapi5-javadoc-5.0.18-1jpp_3fc) scriptlet failed, exit status 1
|    2:servletapi5            ########################################### [100%]



This is caused by the

| $ rpm -q --scripts servletapi5-javadoc
| postinstall scriptlet (using /bin/sh):
| rm -f /usr/share/javadoc/servletapi5
| rm -f /usr/share/javadoc/jsp-api
| ln -s servletapi5-5.0.18 /usr/share/javadoc/servletapi5
| ln -s jsp-api-5.0.18 /usr/share/javadoc/jsp-api


script which does not check whether /usr/share is mounted read-only.

Note that the %post script of the main-package is ok; it uses
'update-alternatives' which seems to operate in a more clever way.


See bug #51193 for additional information.



Version-Release number of selected component (if applicable):

servletapi5-5.0.18-1jpp_3fc


How reproducible:

100%



Additional info:

afais, most of the other java-packages are affected also.

Comment 1 Fernando Nasser 2004-12-07 13:29:33 UTC
/usr/share mounted as read-only is not supported.

Out of curiosity, why would someone want to do that?

Regards.

Comment 2 Enrico Scholz 2004-12-07 13:39:13 UTC
read-only /usr/share is supported. Please read bug #51193 for details.

Comment 3 Enrico Scholz 2004-12-07 13:58:20 UTC
a more java-package specific explaination can be found in bug #122713

Comment 4 Fernando Nasser 2004-12-07 14:38:58 UTC
No, our Java packages belong to the RHAPS product that does NOT
support read-only /usr/share.

If this feature is deemed necessary, please create an appropriate
"feature request" so it can be evaluated by PM, work estimated,
scheduled and implemented.

In the meanwhile I have raised the issue of  bug #51193  upstream for
opinions on the feasibility of a solution.

Comment 5 Fernando Nasser 2004-12-07 14:41:19 UTC
Correction, the Java-related bug that is to be discussed upstream is
bug #122713

Comment 6 Enrico Scholz 2004-12-07 15:06:16 UTC
No, the java-packages belong to the Fedora Core project which supports
%_netsharedpath.

Comment 7 Fernando Nasser 2004-12-07 15:30:33 UTC
OK, so I am reassigning it so it is handled in a Fedora Core-only context.

Comment 9 Gary Benson 2005-06-03 09:15:49 UTC

*** This bug has been marked as a duplicate of 122713 ***


Note You need to log in before you can comment on or make changes to this bug.