Bug 142104 - /var/log/lastlog doesn't get rotated
Summary: /var/log/lastlog doesn't get rotated
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: logrotate (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-07 12:05 UTC by Noam Meltzer
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-09 13:16:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Noam Meltzer 2004-12-07 12:05:56 UTC
Description of problem:
The log file: /var/log/lastlog doesn't get rotated.

Version-Release number of selected component (if applicable):
[root@mosquito courier]# rpm -q logrotate
logrotate-3.7.1-2

Additional info:
Mandrake, for example has another entry in /etc/logrotate.conf:

/var/log/lastlog {
        monthly
        rotate 1
}

in the remark they say that because no package owns it (and wtmp, like
already done in fedora) it will show in the main conf file.

Comment 1 Peter Vrabec 2004-12-09 13:16:12 UTC
Bug #:   372  

 Additional Comment #1 From Cristian Gafton (gafton@redhat.com)  on
1998-12-10 18:58 -------
Private Comment

lastlog should not be rotated, as it will not grow in size (it stores
the timestamps of the last login for each UID, and the max number of
UIDs is 65535, so ,ax size it will be 64K users * 6 bytes each record.


Note You need to log in before you can comment on or make changes to this bug.