Bug 1421044 (deepin-qml-widgets) - Review Request: deepin-qml-widgets - Deepin QML widgets
Summary: Review Request: deepin-qml-widgets - Deepin QML widgets
Keywords:
Status: CLOSED RAWHIDE
Alias: deepin-qml-widgets
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Zbigniew Jędrzejewski-Szmek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: deepin-tool-kit
Blocks: DeepinDEPackageReview
TreeView+ depends on / blocked
 
Reported: 2017-02-10 08:42 UTC by sensor.wen
Modified: 2018-07-22 13:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-22 13:30:55 UTC
Type: ---
zbyszek: fedora-review+


Attachments (Terms of Use)

Comment 1 Zamir SUN 2017-07-21 15:21:55 UTC
Hi,
Your SPEC is now 2.3.5 while your srpm is 2.3.4. Can you resubmit a 2.3.5 srpm for review?

Comment 3 Zbigniew Jędrzejewski-Szmek 2017-08-04 15:41:35 UTC
- No need to use underscores in %_commit, %_shortcommit.

- F24 is (almost) out, so you can remove the F24-specific workarounds.

- Group:, %defattr(-,root,root,-) → please remove [https://fedoraproject.org/wiki/Packaging:Guidelines#Tags_and_Sections]

- qt5-qtquick1 package has been retired [http://pkgs.fedoraproject.org/cgit/rpms/qt5-qtquick1.git/commit/?id=10624544e5e08a7d917f628733ef3e614a8532dd]. I rebuilt this package without that dependency, and it seems to build fine, but I don't know it there's any effect. Please check.

- The %description doesn't describe the package: it also contains a D-bus activated service. Please describe what the package does more fully.

- deepin-dialog says:
QQmlComponent: Component is not ready
"qrc:///qml/main.qml:46 Type DDialogBox unavailable\nfile:///usr/lib64/qt5/qml/Deepin/Widgets/DDialogBox.qml:11 module \"QtGraphicalEffects\" is not installed\n"
→ I think you need
Requires: qt5-qtgraphicaleffects(?%_isa)
Requires: qt5-qtquickcontrols(?%_isa)

Comment 5 Zbigniew Jędrzejewski-Szmek 2017-08-05 16:33:31 UTC
+ package name is OOK
+ license is acceptable (GPLv3)
+ license is specified correctly
+ %license is used
+ latest version
+ builds and install OK
+ P/R/BR look OK

rpmlint:
> deepin-qml-widgets.x86_64: W: devel-file-in-non-devel-package /usr/lib64/qt5/qml/Deepin/Locale/libdlocale.so
I think that's OK.
> deepin-qml-widgets.x86_64: W: no-manual-page-for-binary deepin-dialog
OK.
> deepin-qml-widgets.x86_64: E: unknown-key RSA#1ae64798 (MD5
No idea what's going on here. rpm version mismatch? Nothing to do with the packag e anyway.
> 1 packages and 0 specfiles checked; 1 errors, 2 warnings.

Package is APPROVED.

The %description is still a very short, but this shouldn't block the package. It would be nice to improve it in the future.

Also, please close the ticket when you have built the package in rawhide, if you do not intend to build it in F26 or earlier. It makes it easier to see which reviews are still active.

Comment 6 Ralph Bean 2017-08-10 17:14:56 UTC
(fedrepo-req-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/deepin-qml-widgets

Comment 7 Ralph Bean 2017-08-10 17:15:22 UTC
(fedrepo-req-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/deepin-qml-widgets

Comment 8 Zamir SUN 2018-07-22 13:30:55 UTC
This is already in Rawhide. Closing on behalf of the Deepin Desktop packaging effort.


Note You need to log in before you can comment on or make changes to this bug.