Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1421072 - [DOCS] Document etcd cluster recovery after node failure + installing new etcd nodes
Summary: [DOCS] Document etcd cluster recovery after node failure + installing new etc...
Keywords:
Status: CLOSED DUPLICATE of bug 1419670
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Ashley Hardin
QA Contact: Johnny Liu
Vikram Goyal
URL:
Whiteboard:
Depends On:
Blocks: 1405338
TreeView+ depends on / blocked
 
Reported: 2017-02-10 09:50 UTC by Jaspreet Kaur
Modified: 2020-05-14 15:37 UTC (History)
5 users (show)

Fixed In Version: etcd-3.1.0-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-23 07:53:51 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jaspreet Kaur 2017-02-10 09:50:17 UTC
Document URL:  Document URL: 
This is a request for replacing section in below article as this doesnt work any more.

https://docs.openshift.com/container-platform/3.4/admin_guide/backup_restore.html#backup-restore-adding-etcd-hosts

Section Number and Name: 
Adding New etcd Hosts

5b. Create a backup of the surviving etcd host, and transfer the contents to the new host:

1.) The given flags are not supported
# etcdctl backup --keep-cluster-id --node-id ${NODE_ID} \
  --data-dir /var/lib/etcd --backup-dir /var/lib/etcd/$NEW_ETCD-backup

 the given flags (--keep-cluster-id --node-id ${NODE_ID}) are not supported.

Also refer : https://bugzilla.redhat.com/show_bug.cgi?id=1419670

There are also known issue with the backup procedure/


Describe the issue:  The steps are not working with etcd 3.0.15 version.

Comment 1 Jaspreet Kaur 2017-02-20 07:29:03 UTC
Also, the location mentioned in docs is incorrect :

 etcdctl -C https://${ETCD_CA_HOST}:2379 \
  --ca-file=/etc/etcd/ca.crt     \
  --cert-file=/etc/etcd/peer.crt     \
  --key-file=/etc/etcd/peer.key member add ${NEW_ETCD} https://${NEW_ETCD_IP}:2380

Comment 7 Stefan Schimanski 2017-02-23 07:53:51 UTC
As Jan is fine with giving this BZ back to the docs team, let's mark it as duplicate of #1419670. Comment 1 is copied to #1419670. So nothing left here.

*** This bug has been marked as a duplicate of bug 1419670 ***


Note You need to log in before you can comment on or make changes to this bug.