Bug 1421075 - allow rules exist which circumvent the deny_ptrace boolean
Summary: allow rules exist which circumvent the deny_ptrace boolean
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 09:58 UTC by Milos Malik
Modified: 2018-04-10 12:26 UTC (History)
6 users (show)

Fixed In Version: selinux-policy-3.13.1-175.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1778919 1807542 (view as bug list)
Environment:
Last Closed: 2018-04-10 12:26:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0763 0 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2018-04-10 12:08:10 UTC

Description Milos Malik 2017-02-10 09:58:13 UTC
Description of problem:
All rules which allow the ptrace operation should be controlled via the deny_ptrace boolean.
* https://fedoraproject.org/wiki/Features/SELinuxDenyPtrace

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.13.1-117.el7.noarch
selinux-policy-3.13.1-117.el7.noarch

How reproducible:
* always

Steps to Reproduce:
# sesearch --allow -C -p ptrace | grep -v deny_ptrace | grep allow
   allow sysadm_t hwloc_dhwd_t : process { transition sigchld sigkill sigstop signull signal ptrace getattr } ; 
   allow abrt_dump_oops_t domain : process { signull ptrace getattr } ; 
#

Actual results:
* the output of above-mentioned command contains 2 allow rules

Expected results:
* the output of above-mentioned command is empty

Comment 9 errata-xmlrpc 2018-04-10 12:26:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0763


Note You need to log in before you can comment on or make changes to this bug.