Bug 1421078 - Wifi no longer available after software update & resolved
Summary: Wifi no longer available after software update & resolved
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 25
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 10:09 UTC by hotmailcomaccount
Modified: 2017-05-22 00:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-22 00:18:07 UTC
Type: Bug


Attachments (Terms of Use)

Description hotmailcomaccount 2017-02-10 10:09:06 UTC
Description of problem:
Wifi capability lost after Fedora 25 update.

Version-Release number of selected component (if applicable):
4.9.8-201.fc25.x86_64

How reproducible:
Very

Steps to Reproduce:
1. Update to 4.9.8-201.fc25.x86_64.
2. Wifi not connected
3. The Belkin USB Wifi adapter functioned reliably prior to software update.

Actual results:
Wifi not connected and no networks displayed

Expected results:
Wifi should connect and available networks should be shown.

Additional info:
Resolved problem as follows:
     Downgraded NetworkManager from NetworkManager-1.4.4-3.fc25.x86_64 to NetworkManager-1.4.2-1.fc25.x86_64

     Downgraded wpa_supplicant from wpa_supplicant-2.6-1.fc25.x86_64 to wpa_supplicant-2.5-5.fc24.x86_64

Comment 1 Thomas Haller 2017-04-26 17:31:25 UTC
Please attach a logfile of NetworkManager.


Does configuring

[device-no-mac-rand]
wifi.scan-rand-mac-address=no

in /etc/NetworkManager/NetworkManager.conf avoid the issue?


Maybe it's a duplicate of bug 1419325

Comment 2 hotmailcomaccount 2017-05-13 20:01:21 UTC
(In reply to Thomas Haller from comment #1)
> Please attach a logfile of NetworkManager.
> 
> 
> Does configuring
> 
> [device-no-mac-rand]
> wifi.scan-rand-mac-address=no
> 
> in /etc/NetworkManager/NetworkManager.conf avoid the issue?
> 
> 
> Maybe it's a duplicate of bug 1419325

Yes, setting those configuration items resolved the problem and thank you for your assistance.


Note You need to log in before you can comment on or make changes to this bug.