Bug 1421089 - cockpit-ovirt fails to build due to missing webpack
Summary: cockpit-ovirt fails to build due to missing webpack
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Generic
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ovirt-4.1.1
: 0.10.7-0.0.13
Assignee: Ryan Barry
QA Contact: Ryan Barry
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 10:20 UTC by Sandro Bonazzola
Modified: 2017-03-03 12:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-21 18:03:28 UTC
oVirt Team: Node
rule-engine: ovirt-4.1+
rule-engine: blocker+
cshao: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 72084 0 master MERGED Don't parameterize package.json, since yarn won't understand 2017-02-10 16:10:17 UTC
oVirt gerrit 72094 0 master MERGED Pull in and extract the yarn cache from ovirt-engine-node-modules 2017-02-10 16:53:18 UTC
oVirt gerrit 72095 0 master MERGED automation: add ovirt-engine-yarn to the list of packages 2017-02-10 16:53:46 UTC

Description Sandro Bonazzola 2017-02-10 10:20:22 UTC
Description of problem:
+ make
make[1]: Entering directory `/home/jenkins/workspace/cockpit-ovirt_master_build-artifacts-el7-x86_64/cockpit-ovirt/tmp.repos/BUILD/cockpit-ovirt-0.10.7-0.0.8'
Making all in dashboard
make[2]: Entering directory `/home/jenkins/workspace/cockpit-ovirt_master_build-artifacts-el7-x86_64/cockpit-ovirt/tmp.repos/BUILD/cockpit-ovirt-0.10.7-0.0.8/dashboard'
test -z "" || npm i
npm run build

> cockpit-ovirt-dashboard@0.10.7-0.0.8 build /home/jenkins/workspace/cockpit-ovirt_master_build-artifacts-el7-x86_64/cockpit-ovirt/tmp.repos/BUILD/cockpit-ovirt-0.10.7-0.0.8/dashboard
> NODE_ENV=production webpack -p --progress

sh: webpack: command not found

Seen on http://jenkins.ovirt.org/user/sbonazzo/my-views/view/Builders/job/cockpit-ovirt_master_build-artifacts-el7-x86_64/172/artifact/exported-artifacts/mock_logs/mocker-epel-7-x86_64.el7.build-artifacts.sh/build-artifacts.sh.log

Comment 1 Red Hat Bugzilla Rules Engine 2017-02-10 10:20:28 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 Ryan Barry 2017-02-10 14:24:45 UTC
It looks like Vojtech already moved to yarn to build ovirt-engine-nodejs-modules.

We'll need some rearranging (adding yarn.lock, removing dashboard/package.json and vdsm/package.json from autoconf -- we don't publish these to npm anyway, so that's probably ok), then waiting for a new ovirt-engine-nodejs-modules to build.

As an intermediate fix, we can always use ovirt-engine-nodejs-modules from the 4.1 released repository, or revert the repo change in your last patch.

I'm not sure what the repos you switched to are.

Comment 3 Ryan Barry 2017-02-10 16:51:44 UTC
Everything is rearranged, but we still need to wait for a new build of ovirt-engine-nodejs-modules for this to work.

Comment 4 dguo 2017-02-14 03:24:56 UTC
Ryan, 

We QE currently might not familiar how to build the cockpit-ovirt, so could you please help to verify this bug if the ovirt-engine-nodejs-modules is ready.

If yes, I will change the QA contact to you.

Comment 5 Ryan Barry 2017-02-14 06:15:17 UTC
Totally OK with me.


Note You need to log in before you can comment on or make changes to this bug.