Bug 1421099 - Disabling swift object versioning with "X-Versions-Location: " does not disable versioning
Summary: Disabling swift object versioning with "X-Versions-Location: " does not disab...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.2
Assignee: Matt Benjamin (redhat)
QA Contact: shilpa
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 10:49 UTC by shilpa
Modified: 2017-07-30 16:02 UTC (History)
9 users (show)

Fixed In Version: RHEL: ceph-10.2.5-25.el7cp Ubuntu: ceph_10.2.5-18redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-14 15:49:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 18852 0 None None None 2017-02-13 15:16:31 UTC
Red Hat Product Errata RHBA-2017:0514 0 normal SHIPPED_LIVE Red Hat Ceph Storage 2.2 bug fix and enhancement update 2017-03-21 07:24:26 UTC

Description shilpa 2017-02-10 10:49:46 UTC
Description of problem:
Enable swift object versioning on a container and create objects. Now disable versioning on the container. Objects created further are still versioned

Version-Release number of selected component (if applicable):
ceph-radosgw-10.2.5-22.el7cp.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Configure object versioning using http://docs.openstack.org/user-guide/cli-swift-set-object-versions.html.
2. Create a container called 'archive' to hold versions and create another container called 'current' to create objects
3. Disable versioning on the container using :"X-Versions-Location: "

Actual results:
All the objects created after disabling versioning continues to have versions.


Additional info:

# curl -i http://rgw/swift/v1/new  -X PUT -H "Content-Length: 0" -H "X-Auth-Token: AUTH_rgwtk0a000000757365723a73776966745ecc9abb899e986e4ee59e582502c432487e760fd55af89cb3a7a3e1f686d8f5e80e350d" -H "X-Versions-Location: "
HTTP/1.1 202 Accepted
X-Trans-Id: tx00000000000000000005e-00589d97e1-148c3-us-east
Content-Length: 0
Accept-Ranges: bytes
Content-Type: text/plain; charset=utf-8
Date: Fri, 10 Feb 2017 10:37:21 GMT

# curl -i http://rgw/swift/v1/new/my-object --data-binary 3 -X PUT -H "Content-Length: 0" -H "X-Auth-Token: AUTH_rgwtk0a000000757365723a73776966745ecc9abb899e986e4ee59e582502c432487e760fd55af89cb3a7a3e1f686d8f5e80e350d"
HTTP/1.1 201 Created
etag: d41d8cd98f00b204e9800998ecf8427e
Last-Modified: Fri, 10 Feb 2017 10:37:36 GMT
X-Trans-Id: tx00000000000000000005f-00589d97f0-148c3-us-east
Content-Type: text/plain; charset=utf-8
Content-Length: 0
Date: Fri, 10 Feb 2017 10:37:36 GMT


# swift -A http://rgwauth/1.0 -U user:swift -K 'uYh9A94G2xF6CHZujkcAYpjK4NAJJR25LwlBfWxc' list archive
009my-object/1486723005.128338

# curl -i http://rgw/swift/v1/new/my-object --data-binary 2 -X PUT -H "Content-Length: 0" -H "X-Auth-Token: AUTH_rgwtk0a000000757365723a73776966745ecc9abb899e986e4ee59e582502c432487e760fd55af89cb3a7a3e1f686d8f5e80e350d"
HTTP/1.1 201 Created
etag: d41d8cd98f00b204e9800998ecf8427e
Last-Modified: Fri, 10 Feb 2017 10:37:52 GMT
X-Trans-Id: tx000000000000000000063-00589d9800-148c3-us-east
Content-Type: text/plain; charset=utf-8
Content-Length: 0
Date: Fri, 10 Feb 2017 10:37:52 GMT

# swift -A http://rgw/auth/1.0 -U user:swift -K 'uYh9A94G2xF6CHZujkcAYpjK4NAJJR25LwlBfWxc' list archive
009my-object/1486723005.128338
009my-object/1486723056.174475

Comment 13 errata-xmlrpc 2017-03-14 15:49:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0514.html


Note You need to log in before you can comment on or make changes to this bug.