Bug 1421102 - Meteric details are missing of any host of OSP-Director.
Summary: Meteric details are missing of any host of OSP-Director.
Keywords:
Status: CLOSED DUPLICATE of bug 1421103
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: C&U Capacity and Utilization
Version: 5.6.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: GA
: cfme-future
Assignee: Greg Blomquist
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 10:54 UTC by Neha Chugh
Modified: 2017-02-20 04:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-16 15:07:53 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Neha Chugh 2017-02-10 10:54:33 UTC
Description of problem:
Metric details are missing for any hosts of Openstack Platform Director system.

Version-Release number of selected component (if applicable):
5.6.0 -> CFME
Installed Version of RHOS is 9.

How reproducible:
Always at Customer end.

Steps to Reproduce:
1. Select any host from OSP-Director Provider
2. Click on Monitoring button and selecting "Utilization" returns an missing details of Metrics.
3. Exception observed in evm.log is related to read time out when there is break in connectivity between cf and OSP.
[----] E, [2017-02-10T10:47:49.644386 #20116:b3b988] ERROR -- : MIQ(ManageIQ::Providers::Openstack::InfraManager::MetricsCapture#perf_collect_metrics) [realtime] for: [ManageIQ::Providers::Openstack::InfraManager::Host], [1], [355b8af5-818f-40e3-b0a6-56d7e8ea3f41 (NovaCompute)]   Timings at time of 
error: {:capture_state=>0.03525042533874512, :connect=>62.28718280792236}

Actual results:

Metric details are missing with read time out exception.

Expected results:

Metric details should be visible.

Additional info:

During troubleshooting process, we checked the following stuff:

1. Checking the ceilometer service is up or not?
 Status: checked the #openstack service-status and #ceilometer meter-list providing all the metering details.

2. Checked the Network connectivity between cfme and OSP
Status: Deployed an appliance on the provider and have it act as proxy.
For proxy or worker appliance,  one worker appliance
created in the same network and connected it to the master database. 
On this new appliance, Enabled only the c&u roles.

3. Checking the connectivity to metering service from the cfproxy.local appliance using curl command.

Status: Checked, ceilometer api is providing the metering details.

Comment 2 Greg Blomquist 2017-02-16 15:07:53 UTC

*** This bug has been marked as a duplicate of bug 1421103 ***


Note You need to log in before you can comment on or make changes to this bug.