Bug 142111 - Menu editing disabled for both users and root
Menu editing disabled for both users and root
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-07 08:48 EST by David Savage
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 09:32:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Savage 2004-12-07 08:48:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Editing of the menu via nautilus [applications:///] returns a message
that the file to be edited is read-only.

And editing via the context menu is disabled.

I have not found any work-around.


Version-Release number of selected component (if applicable):
kernel-2.6.9-1.667  gnome 2.8.?

How reproducible:
Always

Steps to Reproduce:
1. From 'Applications' click into a sub-menu
2. right click an entry
3. attempt to remove the entry or add a new entry

    

Actual Results:  The context menu item is disabled


Expected Results:  Freedom to use the context menu item (at least for
root)


Additional info:

I've read somewhere that redhat have switched this feature off due to
some issues with gnome. However I have also read that gnome have
resolved the issues and that it is now just redhat that need to
re-instate this functionality.
Comment 1 rob versluis 2004-12-08 05:41:38 EST
The work-around with ~/.gnome2/vfolders also has disappeared with the
comming of FC3! As system admin I need to have a way to create user
defined menu's... At the moment I can't use FC3 for this reason.
Comment 2 rob versluis 2004-12-08 05:46:51 EST
Editing of the menu's via nautilus [applications:///] in other
distro's is a common praxis. So why not in FC3?
Comment 3 rob versluis 2004-12-09 14:53:36 EST
I found out that there is an organisation called FreeDesktop.org who
wants to build a base platform for desktop software on Linux and UNIX.
FC3 follows those guidelines as defined by this organisation.
In praxis: ~/.config/menus, ~/.local/share/applications and
~/.local/share/desktop-directories are the places to put the
customized menus, desktop and directory files.
Comment 4 Mark McLoughlin 2004-12-20 09:32:15 EST
Fedora Core and (since GNOME 2.9) GNOME upstream uses the relatively
new menu specification from freedesktop.org. This effectively means
that in order to edit the menus you need to edit the
/etc/xdg/menus/*.menu files manually.

The plan to resolve this is to:

  1) Have a relatively simple menu editor for users which allows
     you to disable menu items and perhaps have a personal
     folder in the menus

  2) A much more complicated editor for sysadmins who need to 
     completely re-organise menus. This editor will fully expose
     the idea that the menu is constructed by a vfolder-like
     query of the .desktop files on the system.

However, if and when this happens, it'll happen upstream. Closing UPSTREAM

Note You need to log in before you can comment on or make changes to this bug.