Bug 1421120 - WebUI - User groups - filter issue
Summary: WebUI - User groups - filter issue
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 12:05 UTC by Pavel Picka
Modified: 2017-03-09 11:54 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-09 11:54:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
screen (195.14 KB, image/png)
2017-02-28 08:14 UTC, Pavel Picka
no flags Details

Description Pavel Picka 2017-02-10 12:05:44 UTC
Description of problem:
Allow user groups to create keytab - filter - if use 'group' show admins, trust, ipausers | but otherway working as should

Version-Release number of selected component (if applicable):


How reproducible:
always


Steps to Reproduce:
1. in WebUI 
2. filter 'group' when adding 'groups to create keytab' 

Actual results:
shows admins, trust, ipauser

Expected results:
show groups with 'group' keyword inside

Additional info:
firefox52

Comment 4 Martin Babinsky 2017-02-10 13:24:03 UTC
Pavel,

the description of the issue is very confusing and we are unable to discern what the problem is. Please consult http://www.chiark.greenend.org.uk/~sgtatham/bugs.html and try do describe the bug in greater detail using proper language.

Comment 5 Petr Vobornik 2017-02-10 14:33:07 UTC
I'm guessing: the search in member adder dialog is probably doing general search equivalent to:
`ipa group-find group` 

But groups is probably part of DN or DN of other search attribute so it matches all these group.  And option would be to let UI to search only in group CNs but that won't work because 'attribute' level searches use exact match and not wildcard match.

Comment 6 Pavel Picka 2017-02-28 08:14:33 UTC
Created attachment 1258291 [details]
screen

Comment 8 Petr Vobornik 2017-03-02 16:36:13 UTC
Based on the screenshot, it is as I wrote in comment 5. CLI test: 

$ ipa group-find group
----------------
3 groups matched
----------------
  Group name: admins
  Description: Account administrators group
  GID: 510800000

  Group name: ipausers
  Description: Default group for all users

  Group name: trust admins
  Description: Trusts administrators group
----------------------------
Number of entries returned 3
----------------------------

$ ipa group-find default
---------------
1 group matched
---------------
  Group name: ipausers
  Description: Default group for all users
----------------------------
Number of entries returned 1
----------------------------

I.e. it also searches in other fields - description.


Web UI cannot fix it without extending API, reason is:

$ ipa group-find --group-name='ipausers'
---------------
1 group matched
---------------
  Group name: ipausers
  Description: Default group for all users
----------------------------
Number of entries returned 1
----------------------------


$ ipa group-find --group-name='ipa'
----------------
0 groups matched
----------------
----------------------------
Number of entries returned 0
----------------------------


$ ipa group-find --group-name='*ipa*'
----------------
0 groups matched
----------------
----------------------------
Number of entries returned 0
----------------------------

I.e. options for specifying specific search attrs doesn't support wildcards - bug https://pagure.io/freeipa/issue/888

Comment 9 Petr Vobornik 2017-03-09 11:54:28 UTC
Closing as won't fix given it is a duplicate of upstream https://pagure.io/freeipa/issue/888 and there is no plan to implement it now.


Note You need to log in before you can comment on or make changes to this bug.