Bug 142117 - Add support for 'make cloneconfig'
Add support for 'make cloneconfig'
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-07 09:20 EST by Timur Tabi
Modified: 2015-01-04 17:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 23:41:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timur Tabi 2004-12-07 09:20:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a4) Gecko/20040927

Description of problem:
The SUSE distributions have an additional make target called 'cloneconfig'.  This target creates a .config file that matches the currently running kernel.  All it does is copy /proc/config.gz to .config and then configure the kernel.  However, the real value of this is that all SUSE version ship with /proc/config.gz turned on by default.  This makes it trivial to rebuild the kernel with the same options as it was installed.

At our company, we have a driver that works with several different 2.4 and 2.6 kernels, and our number one problem is getting our customers to have a properly configured kernel so that they can build our driver.  Customers who have SUSE Linux are much easier to work with than users of other distros, mainly because of 'cloneconfig'.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
N/A

Additional info:
Comment 1 Dave Jones 2004-12-07 23:41:01 EST
cp /boot/config-`uname -r` .config
make oldconfig

The /proc stuff is not going to be enabled, as it serves no purpose other than
to waste memory for 99% of users.

Note You need to log in before you can comment on or make changes to this bug.