Bug 1421171 - OCP deployment fails at 70% during TASK [execute atomic-openshift-installer] openshift-enterprise 3.4 is not an installable variant.
Summary: OCP deployment fails at 70% during TASK [execute atomic-openshift-installer] ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - OpenShift
Version: 1.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 1.1
Assignee: Dylan Murray
QA Contact: Landon LaSmith
Derek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 14:18 UTC by Landon LaSmith
Modified: 2017-02-28 01:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-28 01:46:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
ansible log (731.84 KB, text/plain)
2017-02-10 14:18 UTC, Landon LaSmith
no flags Details
atomic installers answers file (2.22 KB, text/plain)
2017-02-10 14:20 UTC, Landon LaSmith
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:0335 0 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.1 2017-02-28 06:36:13 UTC

Description Landon LaSmith 2017-02-10 14:18:39 UTC
Created attachment 1249047 [details]
ansible log

Description of problem: OpenShift (Single availability and HA) deployments on RHV and RHVSH are failing at 70% with ansible failure below

2017-02-10 03:20:03,747 p=22954 u=foreman | TASK [execute atomic-openshift-installer] **************************************
2017-02-10 03:20:04,335 p=22954 u=foreman | fatal: [ocpha-ocp-master1.example.com]: FAILED! => {"changed": true, "cmd": "atomic-openshift-installer -v -u -c /tmp/atomic-openshift-installer.answers.cfg.yml install", "delta": "0:00:00.260777", "end": "2017-02-10 03:20:02.996316", "failed": true, "rc": 1, "start": "2017-02-10 03:20:02.735539", "stderr": "", "stdout": "openshift-enterprise 3.4 is not an installable variant.", "stdout_lines": ["openshift-enterprise 3.4 is not an installable variant."], "warnings": []}
Version-Release number of selected component (if applicable):

QCI Media Version: QCI-1.1-RHEL-7-20170209.t.1

How reproducible: Multiple job runs but might be 100%

Steps to Reproduce:
1. Install QCI from iso
2. Create and start a deployment with OpenShift

Actual results: Deployment fails at 70%

Expected results: OCP ansible task executing atomic-installer succeeds

Additional info: Originally encountered on a baremetal deployment of OCPHA with 1 engine and 3 hypervisors.  Additional nested virt jobs on OCP Single availability encountered the issue.

Comment 1 Landon LaSmith 2017-02-10 14:20:09 UTC
Created attachment 1249048 [details]
atomic installers answers file

Comment 2 Landon LaSmith 2017-02-10 14:46:44 UTC
atomic openshift rpm version is atomic-openshift-utils-3.3.61-1.git.0.27743e6.el7.noarch so using 3.3 for the variant will allow it to proceed

Comment 4 Dylan Murray 2017-02-10 15:45:19 UTC
https://github.com/fusor/fusor/pull/1369

Comment 5 Dylan Murray 2017-02-10 16:17:21 UTC
This is fixed in QCI-1.1-RHEL-7-20170210.t.0.

Comment 6 Landon LaSmith 2017-02-17 17:58:59 UTC
VERIFIED. atomic version 3.4 is in use

QCI Media Version: QCI-1.1-RHEL-7-20170216.0

Comment 8 errata-xmlrpc 2017-02-28 01:46:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:0335


Note You need to log in before you can comment on or make changes to this bug.