Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1421172 - ath10k driver prevent suspend to RAM on kernel 4.9. Worked on 4.8
Summary: ath10k driver prevent suspend to RAM on kernel 4.9. Worked on 4.8
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 14:31 UTC by Enrico Tagliavini
Modified: 2019-01-09 12:54 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-12 10:25:48 UTC
Type: Bug


Attachments (Terms of Use)
journalctl -f output while triggering the issue (8.91 KB, text/plain)
2017-02-10 14:31 UTC, Enrico Tagliavini
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Linux Kernel 193141 0 None None None 2017-02-10 14:31:05 UTC

Description Enrico Tagliavini 2017-02-10 14:31:05 UTC
Created attachment 1249049 [details]
journalctl -f output while triggering the issue

Description of problem:
Attempting to suspend to RAM will fail. Screen goes black for 5-10 seconds and then the desktop comes back instead of suspending the laptop. dmesg shows a firmware crash for the wireless. If I modprobe -r ath10k_pci and then attempt the suspend to ram it succeed. That's my main reason to think this is a regression in ath10k_pci.

Version-Release number of selected component (if applicable):
Happened from kernel 4.9.4 (firt 4.9 to hit stable) to 4.9.7 (latest at the time of this writing). Was working fine with 4.8.16
root@alientux ~ # rpm -qa | grep linux-firmware
linux-firmware-20160923-68.git42ad5367.fc24.noarch
and also reproduced with a recent update:
root@enrico-dell ~ # rpm -qa | grep linux-firmware
linux-firmware-20161205-69.git91ddce49.fc24.noarch

How reproducible:
Always

Steps to Reproduce:
1. Make sure ath10k_pci driver is loaded (if unloaded before attempting the suspend it will actually succeed), no need to be actually connected to a wireless network
2. Trigger the suspend to RAM. I use KDE plasma as DE, hit alt + f2 to show krunner, write "suspend" so the "Suspend to RAM" action is displayed
3. Click or hit enter on the "Suspend to RAM" entry in krunner

Actual results:
Screen goes black for 5 - 10 seconds, but mouse cursor is still there, then desktop comes back

Expected results:
Laptop should suspend as it was with kernel 4.8 without removing the wireless kernel module first

Additional info:
Two weeks ago I opened an issue on the upstream linux kernel bugzilla and also wrote to the ath10k mailing list [1]. No answer so far.

Somebody in #fedora on IRC suggested to also open the bug on this bugzilla, so here it is :).

[1] http://lists.infradead.org/pipermail/ath10k/2017-January/009069.html

Comment 1 Justin M. Forbes 2017-04-11 14:58:50 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 24 kernel bugs.

Fedora 25 has now been rebased to 4.10.9-100.fc24.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.

If you experience different issues, please open a new bug report for those.

Comment 2 Enrico Tagliavini 2017-04-11 15:07:53 UTC
Still happens on Fedora 25 with 4.10 kernel series.

Comment 3 Fedora End Of Life 2017-11-16 18:32:12 UTC
This message is a reminder that Fedora 25 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 25. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '25'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 25 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 4 Fedora End Of Life 2017-12-12 10:25:48 UTC
Fedora 25 changed to end-of-life (EOL) status on 2017-12-12. Fedora 25 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.