Bug 1421219 - [abrt] xfdashboard: poll_for_event(): xfdashboard killed by SIGABRT
Summary: [abrt] xfdashboard: poll_for_event(): xfdashboard killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfdashboard
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:d804c05d622851bd15bf743ce7e...
: 1383858 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 15:56 UTC by Gerardo Rosales
Modified: 2017-06-09 18:58 UTC (History)
4 users (show)

Fixed In Version: xfdashboard-0.7.2-1.fc25 xfdashboard-0.7.2-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-26 04:03:00 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (17.79 KB, text/plain)
2017-02-10 15:56 UTC, Gerardo Rosales
no flags Details
File: cgroup (242 bytes, text/plain)
2017-02-10 15:56 UTC, Gerardo Rosales
no flags Details
File: core_backtrace (5.45 KB, text/plain)
2017-02-10 15:56 UTC, Gerardo Rosales
no flags Details
File: dso_list (9.54 KB, text/plain)
2017-02-10 15:56 UTC, Gerardo Rosales
no flags Details
File: environ (1.35 KB, text/plain)
2017-02-10 15:56 UTC, Gerardo Rosales
no flags Details
File: limits (1.29 KB, text/plain)
2017-02-10 15:56 UTC, Gerardo Rosales
no flags Details
File: maps (44.26 KB, text/plain)
2017-02-10 15:56 UTC, Gerardo Rosales
no flags Details
File: mountinfo (3.51 KB, text/plain)
2017-02-10 15:56 UTC, Gerardo Rosales
no flags Details
File: namespaces (102 bytes, text/plain)
2017-02-10 15:56 UTC, Gerardo Rosales
no flags Details
File: open_fds (491 bytes, text/plain)
2017-02-10 15:56 UTC, Gerardo Rosales
no flags Details
File: proc_pid_status (1.11 KB, text/plain)
2017-02-10 15:56 UTC, Gerardo Rosales
no flags Details
File: var_log_messages (888 bytes, text/plain)
2017-02-10 15:56 UTC, Gerardo Rosales
no flags Details

Description Gerardo Rosales 2017-02-10 15:56:07 UTC
Description of problem:
Installed Fedora 25 (XFCE spin) in a ASUS ROG GL551V. 

Hardware:
* Latest updates
* 4.9.8-201.fc25.x86_64
* NVIDIA Geforce GTX 960M (closed source drivers via negativo17 repo)

Launched xfdashboard and the error notification came up. 
Restarted the app and tried again, same issue happened.

Version-Release number of selected component:
xfdashboard-0.7.0-1.fc25

Additional info:
reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        xfdashboard
crash_function: poll_for_event
executable:     /usr/bin/xfdashboard
global_pid:     2534
kernel:         4.9.8-201.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 poll_for_event at xcb_io.c:256
 #5 poll_for_response at xcb_io.c:274
 #7 _XGetRequest at XlibInt.c:1707
 #8 XCreateColormap at CrCmap.c:44
 #9 create_context at winsys/cogl-winsys-glx.c:1123
 #10 _cogl_winsys_display_setup at winsys/cogl-winsys-glx.c:1226
 #11 cogl_display_setup at cogl-display.c:154
 #12 clutter_backend_do_real_create_context at clutter-backend.c:330
 #13 clutter_backend_real_create_context at clutter-backend.c:414
 #14 _clutter_feature_init at clutter-feature.c:107

Potential duplicate: bug 1383858

Comment 1 Gerardo Rosales 2017-02-10 15:56:12 UTC
Created attachment 1249062 [details]
File: backtrace

Comment 2 Gerardo Rosales 2017-02-10 15:56:13 UTC
Created attachment 1249063 [details]
File: cgroup

Comment 3 Gerardo Rosales 2017-02-10 15:56:14 UTC
Created attachment 1249064 [details]
File: core_backtrace

Comment 4 Gerardo Rosales 2017-02-10 15:56:15 UTC
Created attachment 1249065 [details]
File: dso_list

Comment 5 Gerardo Rosales 2017-02-10 15:56:16 UTC
Created attachment 1249066 [details]
File: environ

Comment 6 Gerardo Rosales 2017-02-10 15:56:17 UTC
Created attachment 1249067 [details]
File: limits

Comment 7 Gerardo Rosales 2017-02-10 15:56:18 UTC
Created attachment 1249068 [details]
File: maps

Comment 8 Gerardo Rosales 2017-02-10 15:56:19 UTC
Created attachment 1249069 [details]
File: mountinfo

Comment 9 Gerardo Rosales 2017-02-10 15:56:20 UTC
Created attachment 1249070 [details]
File: namespaces

Comment 10 Gerardo Rosales 2017-02-10 15:56:21 UTC
Created attachment 1249071 [details]
File: open_fds

Comment 11 Gerardo Rosales 2017-02-10 15:56:22 UTC
Created attachment 1249072 [details]
File: proc_pid_status

Comment 12 Gerardo Rosales 2017-02-10 15:56:23 UTC
Created attachment 1249073 [details]
File: var_log_messages

Comment 13 Kevin Fenzi 2017-02-10 23:02:48 UTC
Do you get any more output if you try and start it from a terminal?

How about with 'xfdashboard -d' ?

Comment 14 Mukundan Ragavan 2017-02-10 23:15:19 UTC
*** Bug 1383858 has been marked as a duplicate of this bug. ***

Comment 15 Mukundan Ragavan 2017-02-10 23:20:57 UTC
Filed upstream

https://github.com/gmc-holle/xfdashboard/issues/140

Comment 16 Mukundan Ragavan 2017-02-13 22:16:31 UTC
Can you please run xfdashboard using

CLUTTER_DEBUG=backend xfdashboard

and provide the output (or what happens)?

Comment 17 Gerardo Rosales 2017-02-17 01:06:37 UTC
Sorry for the delay, the laptop is not mine so I had to request the info.

These are the messages that appear when executed xfdashboard -d or CLUTTER_DEBUG=backend xfdashboard in a terminal.

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
xfdashboard: xcb_io.c:259: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.
Aborted

Let us know if there is something else we can do/provide.

Comment 18 Gerardo Rosales 2017-02-19 23:55:53 UTC
I've checked the upstream bug report (thanks Mukundan), based on the latest input we checked again and this is what we got.

[user@pc ~]$ CLUTTER_DEBUG=BACKEND COGL_DEBUG=winsys xfdashboard
Cogl-Message: [WINSYS] cogl-xlib-renderer.c:415 & Outputs:
Cogl-Message: [WINSYS] cogl-xlib-renderer.c:454 &     eDP-1-1: +0+0x1920x1080 mm=344x193 dpi=141.8x142.1 subpixel_order=horizontal_rgb refresh_rate=60.008
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Cogl-Message: [WINSYS] winsys/cogl-winsys-glx.c:687 &   GLX Extensions: GLX_ARB_create_context GLX_ARB_create_context_profile GLX_ARB_create_context_robustness GLX_ARB_fbconfig_float GLX_ARB_framebuffer_sRGB GLX_ARB_get_proc_address GLX_ARB_multisample GLX_EXT_import_context GLX_EXT_visual_info GLX_EXT_visual_rating GLX_EXT_framebuffer_sRGB GLX_EXT_create_context_es2_profile GLX_EXT_create_context_es_profile GLX_MESA_multithread_makecurrent GLX_SGI_make_current_read GLX_SGI_swap_control GLX_SGI_video_sync GLX_SGIX_fbconfig GLX_SGIX_pbuffer GLX_EXT_texture_from_pixmap GLX_EXT_buffer_age 
Cogl-Message: [WINSYS] winsys/cogl-winsys-glx.c:988 & Found an ARGB FBConfig [index:1]
Cogl-Message: [WINSYS] winsys/cogl-winsys-glx.c:1076 & Creating GLX Context (display: 0x55c1ac8520c0)
Cogl-Message: [WINSYS] winsys/cogl-winsys-glx.c:1002 & Using the first available FBConfig
Cogl-Message: [WINSYS] winsys/cogl-winsys-glx.c:1076 & Creating GLX Context (display: 0x55c1ac8520c0)
Cogl-Message: [WINSYS] cogl-xlib-renderer.c:415 & Outputs:
Cogl-Message: [WINSYS] cogl-xlib-renderer.c:454 &     eDP-1-1: +0+0x1920x1080 mm=344x193 dpi=141.8x142.1 subpixel_order=horizontal_rgb refresh_rate=60.008
Cogl-Message: [WINSYS] winsys/cogl-winsys-glx.c:687 &   GLX Extensions: GLX_ARB_create_context GLX_ARB_create_context_profile GLX_ARB_create_context_robustness GLX_ARB_fbconfig_float GLX_ARB_framebuffer_sRGB GLX_ARB_get_proc_address GLX_ARB_multisample GLX_EXT_import_context GLX_EXT_visual_info GLX_EXT_visual_rating GLX_EXT_framebuffer_sRGB GLX_EXT_create_context_es2_profile GLX_EXT_create_context_es_profile GLX_MESA_multithread_makecurrent GLX_SGI_make_current_read GLX_SGI_swap_control GLX_SGI_video_sync GLX_SGIX_fbconfig GLX_SGIX_pbuffer GLX_EXT_texture_from_pixmap GLX_EXT_buffer_age 
Cogl-Message: [WINSYS] winsys/cogl-winsys-glx.c:988 & Found an ARGB FBConfig [index:1]
Cogl-Message: [WINSYS] winsys/cogl-winsys-glx.c:1076 & Creating GLX Context (display: 0x55c1ac8520c0)
Cogl-Message: [WINSYS] winsys/cogl-winsys-glx.c:1103 & Setting indirect context
Cogl-Message: [WINSYS] winsys/cogl-winsys-glx.c:1158 & Selecting dummy 0x3400006 for the GLX context
Cogl-Message: [WINSYS] winsys/cogl-winsys-glx.c:988 & Found an ARGB FBConfig [index:1]
Cogl-Message: [WINSYS] winsys/cogl-winsys-glx.c:1076 & Creating GLX Context (display: 0x55c1ac8520c0)
Cogl-Message: [WINSYS] winsys/cogl-winsys-glx.c:1103 & Setting indirect context
[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
xfdashboard: xcb_io.c:259: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.
Aborted (core dumped)

Also we checked the packages installed

[user@pc ~]$ dnf list installed clutter cogl gtk* mesa*
Installed Packages
clutter.x86_64                1.26.0-1.fc25                  @koji-override-0
cogl.x86_64                   1.22.2-2.fc25                  @koji-override-0
gtk-murrine-engine.x86_64     0.98.2-10.fc25                 @koji-override-0
gtk-unico-engine.x86_64       1.0.3-0.7.20140109bzr152.fc24  @koji-override-0
gtk-update-icon-cache.x86_64  3.22.7-1.fc25                  @updates
gtk-vnc2.x86_64               0.7.0-1.fc25                   @updates
gtk-xfce-engine.x86_64        3.2.0-3.fc24                   @koji-override-0
gtk2.x86_64                   2.24.31-2.fc25                 @koji-override-0
gtk2-engines.x86_64           2.20.2-11.fc24                 @koji-override-0
gtk3.x86_64                   3.22.7-1.fc25                  @updates
gtkmm24.x86_64                2.24.5-1.fc25                  @koji-override-0
gtkmm30.x86_64                3.22.0-1.fc25                  @koji-override-0
gtkspell.x86_64               2.0.16-11.fc24                 @koji-override-0
mesa-dri-drivers.i686         13.0.3-5.fc25                  @updates
mesa-dri-drivers.x86_64       13.0.3-5.fc25                  @updates
mesa-filesystem.i686          13.0.3-5.fc25                  @updates
mesa-filesystem.x86_64        13.0.3-5.fc25                  @updates
mesa-libEGL.i686              13.0.3-5.fc25                  @updates
mesa-libEGL.x86_64            13.0.3-5.fc25                  @updates
mesa-libGL.i686               13.0.3-5.fc25                  @updates
mesa-libGL.x86_64             13.0.3-5.fc25                  @updates
mesa-libGL-devel.x86_64       13.0.3-5.fc25                  @updates
mesa-libGLES.x86_64           13.0.3-5.fc25                  @updates
mesa-libGLU.i686              9.0.0-10.fc24                  @fedora
mesa-libGLU.x86_64            9.0.0-10.fc24                  @fedora
mesa-libGLU-devel.x86_64      9.0.0-10.fc24                  @fedora
mesa-libOSMesa.i686           13.0.3-5.fc25                  @updates
mesa-libOSMesa.x86_64         13.0.3-5.fc25                  @updates
mesa-libgbm.i686              13.0.3-5.fc25                  @updates
mesa-libgbm.x86_64            13.0.3-5.fc25                  @updates
mesa-libglapi.i686            13.0.3-5.fc25                  @updates
mesa-libglapi.x86_64          13.0.3-5.fc25                  @updates
mesa-libwayland-egl.x86_64    13.0.3-5.fc25                  @updates
mesa-libxatracker.x86_64      13.0.3-5.fc25                  @updates
mesa-vulkan-drivers.x86_64    13.0.3-5.fc25                  @updates

The nvidia driver version installed is 378.13.

Comment 19 Fedora Update System 2017-05-14 00:45:33 UTC
xfdashboard-0.7.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-bfd9026dac

Comment 20 Fedora Update System 2017-05-15 10:20:31 UTC
xfdashboard-0.7.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-bfd9026dac

Comment 21 Fedora Update System 2017-05-16 01:34:07 UTC
xfdashboard-0.7.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6fa0f5cf36

Comment 22 Fedora Update System 2017-05-16 01:34:26 UTC
xfdashboard-0.7.2-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5a9bc913ed

Comment 23 Fedora Update System 2017-05-16 06:10:34 UTC
xfdashboard-0.7.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6fa0f5cf36

Comment 24 Fedora Update System 2017-05-17 01:09:11 UTC
xfdashboard-0.7.2-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-5a9bc913ed

Comment 25 Fedora Update System 2017-05-26 04:03:00 UTC
xfdashboard-0.7.2-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2017-06-09 18:58:52 UTC
xfdashboard-0.7.2-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.