Bug 142123 - Perms on logical volumes break amanda
Summary: Perms on logical volumes break amanda
Status: CLOSED DUPLICATE of bug 141050
Alias: None
Product: Fedora
Classification: Fedora
Component: lvm2   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alasdair Kergon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-07 15:12 UTC by Dave Sill
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 17:38:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Sill 2004-12-07 15:12:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040913

Description of problem:
Upgraded FC1 system to FC3 and amanda dumps broke because the device
for the logical volume is readable only by root.

# ls -l /dev/mapper/Volume00-LogVol00
brw-------  1 root root 253, 0 Dec  6 14:03 /dev/mapper/Volume00-LogVol00
#

Don't know if this is true for a fresh FC3 install.

Version-Release number of selected component (if applicable):
udev-039-10.FC3.4

How reproducible:
Always

Steps to Reproduce:
1.Install FC1
2.Put / on a logical volume
3.Configure amanda
4.Upgrade to FC3
5.Attempt amanda backup
    

Actual Results:  FAILURE AND STRANGE DUMP SUMMARY:
  daacwrx    / lev 0 FAILED [disk / offline on daacwrx?]

daacwrx   /              0   FAILED
--------------------------------------------


Expected Results:  daacwrx   /boot          0     8160     8160   -- 
   0:01 8080.7    0:06 1376.4


Additional info:

Comment 1 Harald Hoyer 2004-12-07 15:20:39 UTC
this would be lvm called in rc.sysinit:
if [ -x /sbin/lvm.static ]; then
    if ! LC_ALL=C fgrep -q "device-mapper" /proc/devices 2>/dev/null ;
then
        modprobe dm-mod >/dev/null 2>&1
    fi
    echo "mkdmnod" | /sbin/nash --quiet >/dev/null 2>&1
    [ -n "$SELINUX" ] && restorecon /dev/mapper/control >/dev/null 2>&1
    if [ -c /dev/mapper/control -a -x /sbin/lvm.static ]; then
        if /sbin/lvm.static vgscan --mknodes --ignorelockingfailure >
/dev/null 2>&1 ; then
            action $"Setting up Logical Volume Management:"
/sbin/lvm.static vgchange -a y
--ignorelockingfailure
        fi
    fi
fi

According to my system, the logical Volumes are not part of the udev
database...

[harald@jever ~]$ udevinfo -d |fgrep N:|fgrep map
N: mapper/control
[harald@jever ~]$ ll /dev/mapper/*
crw-------  1 root root  10, 63  6. Dez 12:29 /dev/mapper/control
brw-------  1 root root 253,  0  6. Dez 12:29 /dev/mapper/Vol1-lvol0


Comment 2 Alasdair Kergon 2005-01-05 20:17:54 UTC

*** This bug has been marked as a duplicate of 141050 ***


Note You need to log in before you can comment on or make changes to this bug.