Bug 1421237 - Failed Dependacies when installing to OpenStack Images
Summary: Failed Dependacies when installing to OpenStack Images
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Installer
Version: 2.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.2
Assignee: Christina Meno
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks: 1356451
TreeView+ depends on / blocked
 
Reported: 2017-02-10 17:02 UTC by Randy Perryman
Modified: 2017-12-13 00:24 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-10 17:17:01 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Randy Perryman 2017-02-10 17:02:19 UTC
Installing the following packages to the RHOSP director images: 
repos=(
	    rhel-7-server-rpms
	    rhel-7-server-rhscon-2-agent-rpms
	    rhel-7-server-rhceph-2-mon-rpms
	)
	
	packages=(
	    calamari-server
	    rhscon-agent
	)
	
to the following overcloud image - rhosp-director-images-ipa-10.0-20170201.1.el7ost.noarch
The following Error is encountered:

--> Finished Dependency Resolution
Error: Package: systemd-python-219-30.el7.x86_64 (rhel-7-server-rpms)
           Requires: systemd = 219-30.el7
           Installed: systemd-219-30.el7_3.6.x86_64 (@koji-override-0/7.3)
               systemd = 219-30.el7_3.6
           Available: systemd-208-11.el7.x86_64 (rhel-7-server-rpms)
               systemd = 208-11.el7
           Available: systemd-208-11.el7_0.2.x86_64 (rhel-7-server-rpms)
               systemd = 208-11.el7_0.2
           Available: systemd-208-11.el7_0.4.x86_64 (rhel-7-server-rpms)
               systemd = 208-11.el7_0.4
           Available: systemd-208-11.el7_0.5.x86_64 (rhel-7-server-rpms)
               systemd = 208-11.el7_0.5
           Available: systemd-208-11.el7_0.6.x86_64 (rhel-7-server-rpms)
               systemd = 208-11.el7_0.6
           Available: systemd-208-20.el7.x86_64 (rhel-7-server-rpms)
               systemd = 208-20.el7
           Available: systemd-208-20.el7_1.2.x86_64 (rhel-7-server-rpms)
               systemd = 208-20.el7_1.2
           Available: systemd-208-20.el7_1.3.x86_64 (rhel-7-server-rpms)
               systemd = 208-20.el7_1.3
           Available: systemd-208-20.el7_1.5.x86_64 (rhel-7-server-rpms)
               systemd = 208-20.el7_1.5
           Available: systemd-208-20.el7_1.6.x86_64 (rhel-7-server-rpms)
               systemd = 208-20.el7_1.6
           Available: systemd-219-19.el7.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7
           Available: systemd-219-19.el7_2.4.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7_2.4
           Available: systemd-219-19.el7_2.7.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7_2.7
           Available: systemd-219-19.el7_2.9.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7_2.9
           Available: systemd-219-19.el7_2.11.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7_2.11
           Available: systemd-219-19.el7_2.12.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7_2.12
           Available: systemd-219-19.el7_2.13.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7_2.13
           Available: systemd-219-30.el7.x86_64 (rhel-7-server-rpms)
               systemd = 219-30.el7
Error: Package: glibc-2.17-157.el7.i686 (rhel-7-server-rpms)
           Requires: glibc-common = 2.17-157.el7
           Installed: glibc-common-2.17-157.el7_3.1.x86_64 (@koji-override-0/7.3)
               glibc-common = 2.17-157.el7_3.1
           Available: glibc-common-2.17-55.el7.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-55.el7
           Available: glibc-common-2.17-55.el7_0.1.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-55.el7_0.1
           Available: glibc-common-2.17-55.el7_0.3.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-55.el7_0.3
           Available: glibc-common-2.17-55.el7_0.5.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-55.el7_0.5
           Available: glibc-common-2.17-78.el7.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-78.el7
           Available: glibc-common-2.17-105.el7.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-105.el7
           Available: glibc-common-2.17-106.el7_2.1.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-106.el7_2.1
           Available: glibc-common-2.17-106.el7_2.4.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-106.el7_2.4
           Available: glibc-common-2.17-106.el7_2.6.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-106.el7_2.6
           Available: glibc-common-2.17-106.el7_2.8.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-106.el7_2.8
           Available: glibc-common-2.17-157.el7.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-157.el7


Note You need to log in before you can comment on or make changes to this bug.