Bug 1421247 - start of colord causes selinux denial, comm="colord" name="hwdb.bin"
Summary: start of colord causes selinux denial, comm="colord" name="hwdb.bin"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.4
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 18:02 UTC by Petr Sklenar
Modified: 2017-08-01 15:22 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 15:22:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1861 normal SHIPPED_LIVE selinux-policy bug fix update 2017-08-01 17:50:24 UTC

Description Petr Sklenar 2017-02-10 18:02:47 UTC
Description of problem:
try to start colord 

Version-Release number of selected component (if applicable):
colord-1.2.7-2.el7.x86_64
selinux-policy-3.13.1-117.el7.noarch


How reproducible:
always

Steps to Reproduce:
1. start colord

Actual results:
journalctl:
Feb 10 18:58:46 masox.brq.redhat.com python[28705]: SELinux is preventing /usr/libexec/colord from read access on the file /etc/udev/hwdb.bin.
                                                    
                                                    *****  Plugin catchall (100. confidence) suggests   **************************
                                                    
                                                    If you believe that colord should be allowed read access on the hwdb.bin file by default.
                                                    Then you should report this as a bug.
                                                    You can generate a local policy module to allow this access.
                                                    Do
                                                    allow this access for now by executing:
                                                    # ausearch -c 'colord' --raw | audit2allow -M my-colord
                                                    # semodule -i my-colord.pp
                                                    
Feb 10 18:58:49 masox.brq.redhat.com setroubleshoot[28705]: SELinux is preventing /usr/libexec/colord from read access on the file /etc/udev/hwdb.bin. For complete SELinux m
Feb 10 18:58:49 masox.brq.redhat.com python[28705]: SELinux is preventing /usr/libexec/colord from read access on the file /etc/udev/hwdb.bin.
                                                    
                                                    *****  Plugin catchall (100. confidence) suggests   **************************
                                                    
                                                    If you believe that colord should be allowed read access on the hwdb.bin file by default.
                                                    Then you should report this as a bug.
                                                    You can generate a local policy module to allow this access.
                                                    Do
                                                    allow this access for now by executing:
                                                    # ausearch -c 'colord' --raw | audit2allow -M my-colord
                                                    # semodule -i my-colord.pp



---------------
audit.log:

type=AVC msg=audit(1486720637.555:115): avc:  denied  { read } for  pid=3610 comm="colord" name="hwdb.bin" dev="dm-0" ino=135696345 scontext=system_u:system_r:colord_t:s0 tcontext=system_u:object_r:systemd_hwdb_etc_t:s0 tclass=file
type=AVC msg=audit(1486720637.555:116): avc:  denied  { read } for  pid=3610 comm="colord" name="hwdb.bin" dev="dm-0" ino=135696345 scontext=system_u:system_r:colord_t:s0 tcontext=system_u:object_r:systemd_hwdb_etc_t:s0 tclass=file
type=AVC msg=audit(1486749525.624:824): avc:  denied  { read } for  pid=28700 comm="colord" name="hwdb.bin" dev="dm-0" ino=135696345 scontext=system_u:system_r:colord_t:s0 tcontext=system_u:object_r:systemd_hwdb_etc_t:s0 tclass=file
type=AVC msg=audit(1486749525.624:825): avc:  denied  { read } for  pid=28700 comm="colord" name="hwdb.bin" dev="dm-0" ino=135696345 scontext=system_u:system_r:colord_t:s0 tcontext=system_u:object_r:systemd_hwdb_etc_t:s0 tclass=file


Expected results:
no denial

Additional info:

Comment 3 Milos Malik 2017-02-11 19:27:48 UTC
I believe this bug is a duplicate of BZ#1373082.

Comment 6 errata-xmlrpc 2017-08-01 15:22:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1861


Note You need to log in before you can comment on or make changes to this bug.