Bug 1421262 - Typo in image replacement procedure
Summary: Typo in image replacement procedure
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: RHOS Documentation Team
QA Contact: RHOS Documentation Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 18:54 UTC by David Hill
Modified: 2020-03-11 15:47 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-23 23:14:52 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description David Hill 2017-02-10 18:54:01 UTC
Description of problem:
In section 3.3 of https://access.redhat.com/documentation/en/red-hat-openstack-platform/10/single/upgrading-red-hat-openstack-platform/#sect-Important_Pre-Upgrade_Notes, there's a "-" in the tar command which make it to fail.  It must be "tar xvf" instead of "tar -xvf"

Extract the archives:

$ cd ~/images
$ for i in /usr/share/rhosp-director-images/overcloud-full-latest-10.0.tar /usr/share/rhosp-director-images/ironic-python-agent-latest-10.0.tar; do tar -xvf $i; done


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Copy/paste the procedure
2.
3.

Actual results:
Fails there because of a simple dash

Expected results:
Succeeds

Additional info:

Comment 2 Julie Pichon 2018-03-22 10:18:06 UTC
Moving to documentation component, though the command seems to work for me with the dash ($ tar --version -> tar (GNU tar) 1.26, on 7.4). It also works without so removing it sounds still safer anyway.

Comment 3 Julie 2018-04-18 01:26:40 UTC
hello, from the reading the man page, all the examples have dash, and my understanding is that the command works with or without dash. May I suggest to keep it? 

Cheers,
Julie Wu

Comment 4 Lucy Bopf 2018-04-23 02:41:21 UTC
Moving to 'NEW' to allow for proper scoping by the documentation team.

Comment 5 Julie 2018-04-23 23:14:52 UTC
Closing this bug for now because the current content is also correct. If anyone feels strongly about this bug, please let me know and open a new bug.

Kind regards,
Julie


Note You need to log in before you can comment on or make changes to this bug.