Bug 1421287 - When checking the logs for a pod that has two containers you see "Go to end" instead of "Follow"
Summary: When checking the logs for a pod that has two containers you see "Go to end" ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.3.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Jessica Forrester
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 21:30 UTC by Eric Jones
Modified: 2021-03-11 14:57 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Viewing logs for pods with multiple containers caused weird behavior, especially when switching between containers. The user should now be able to switch between container logs cleanly and the Follow link should work as expected.
Clone Of:
Environment:
Last Closed: 2017-08-10 05:17:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
display follow (39.13 KB, image/png)
2017-07-12 07:43 UTC, shahan
no flags Details
pod_with_two_container (565 bytes, text/plain)
2017-07-12 07:59 UTC, shahan
no flags Details
pod_with_two_container (564 bytes, text/plain)
2017-07-12 08:29 UTC, shahan
no flags Details
mypod_two_containers (687 bytes, text/plain)
2017-07-12 08:33 UTC, shahan
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1716 0 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.6 RPM Release Advisory 2017-08-10 09:02:50 UTC

Description Eric Jones 2017-02-10 21:30:25 UTC
Description of problem:
When a pod is still running the Console normally displays a "Follow" button so that you can follow along with the new logs that are coming in.

If you have a pod running that has two containers in it, the web console appears to display "Go to end" instead, which is usually the option when no more logs are coming in. 

Version-Release number of selected component (if applicable):
OpenShift Master: v3.3.1.3

Comment 9 Jessica Forrester 2017-07-07 17:17:47 UTC
We think its possible this was fixed as early as 3.5 with this PR https://github.com/openshift/origin-web-console/pull/1310 but haven't confirmed it. We definitely no longer see this in master for 3.6

Comment 10 shahan 2017-07-11 08:28:00 UTC
Checked this issue in openshift both v3.6.139 and v3.5.5.30. It works well.
BTW, QE is checking many Modified bugs to see if they're verifiable. Because fixed, moving to Verified. If have other concerns, pls tell me, thx

Comment 11 shahan 2017-07-11 10:47:30 UTC
Since the step of verifying is wrong, please ignore the above comment. Will continue to research how to reproduce this bug tomorrow.  Sorry about that.

Comment 13 shahan 2017-07-12 07:43:33 UTC
Created attachment 1296761 [details]
display follow

Comment 14 shahan 2017-07-12 07:58:43 UTC
Reproduce this bug in the old version and it was fixed in openshift v3.6.139. For a pod with two containers, the web console correctly display "Follow" on the log terminal, see attachment

Comment 15 shahan 2017-07-12 07:59:39 UTC
Created attachment 1296772 [details]
pod_with_two_container

Comment 16 shahan 2017-07-12 08:29:47 UTC
Created attachment 1296778 [details]
pod_with_two_container

Comment 17 shahan 2017-07-12 08:33:21 UTC
Created attachment 1296780 [details]
mypod_two_containers

Comment 19 errata-xmlrpc 2017-08-10 05:17:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716


Note You need to log in before you can comment on or make changes to this bug.