Bug 1421303 - Updating from RHOSP 9 to RHOSP 10 will break on Ceph repositories with some entitlements
Summary: Updating from RHOSP 9 to RHOSP 10 will break on Ceph repositories with some e...
Keywords:
Status: CLOSED DUPLICATE of bug 1405881
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 10.0 (Newton)
Assignee: Sofer Athlan-Guyot
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On: 1405881 1493744
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 23:27 UTC by David Hill
Modified: 2020-12-14 08:09 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-28 13:51:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description David Hill 2017-02-10 23:27:59 UTC
Description of problem:
Updating from RHOSP 9 to RHOSP 10 will break on Ceph repositories with some entitlements

WARNING (shell) "heat deployment-show" is deprecated, please use "openstack software deployment show" instead{  "status": "FAILED",   "server_id": "a53da07d-de70-420e-bdb3-ec54f522f86d",   "config_id": "38e97811-763d-4439-a75e-9458753a9f5d",   "output_values": {    "deploy_stdout": "Repository 'rhel-7-server-openstack-9-director-rpms' is disabled for this system.\nRepository 'rhel-7-server-rhceph-1.3-tools-rpms' is disabled for this system.\nRepository 'rhel-7-server-openstack-9-rpms' is disabled for this system.\nError: 'rhel-7-server-rhceph-2-mon-rpms' does not match a valid repository ID. Use \"subscription-manager repos --list\" to see valid repositories.\nError: 'rhel-7-server-rhceph-2-osd-rpms' does not match a valid repository ID. Use \"subscription-manager repos --list\" to see valid repositories.\nRepository 'rhel-7-server-rhceph-2-tools-rpms' is enabled for this system.\nRepository 'rhel-7-server-openstack-10-rpms' is enabled for this system.\n",     "deploy_stderr": "",     "deploy_status_code": 1  },   "creation_time": "2017-02-10T22:58:17Z",   "updated_time": "2017-02-10T22:59:21Z",   "input_values": {    "update_identifier": "",     "deploy_identifier": "1486767166"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Update from RHOSP 9 to RHOSP 10
2.
3.

Actual results:
Fails

Expected results:
Succeeds

Additional info:

Comment 1 Amit Ugol 2017-03-08 10:41:19 UTC
It seems that there is no working subscription, so upgrade will fail in the initial step. Could you ask to fix the subscription and retest.

Comment 2 David Hill 2017-03-08 16:17:43 UTC
We could update / upgrade openstack but ceph failed because they're not included in the openstack entitlements the customer had.  (I'm pretty sure that was the case)   I've removed all ceph requirements from the templates/shell scripts and managed to go passed through this issue ...

Comment 3 David Hill 2017-03-08 16:18:26 UTC
So maybe we could add such a validation in the shell scripts...

Comment 4 Sofer Athlan-Guyot 2017-05-30 08:06:39 UTC
Going to add a check to only upgrade ceph repo if it was enable to start with.

Comment 7 Sofer Athlan-Guyot 2017-06-26 11:42:56 UTC
Hi,

so this won't fix that as there is an autodetection mechanism in place with the subscription that force the ceph registration.

The root problem is now tracked in bz 1405881.

Comment 8 Sofer Athlan-Guyot 2018-03-28 13:51:09 UTC
1405881 found closure.

*** This bug has been marked as a duplicate of bug 1405881 ***


Note You need to log in before you can comment on or make changes to this bug.