Bug 1421381 - VM Discovery event not present
Summary: VM Discovery event not present
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Control
Version: 5.7.0
Hardware: All
OS: Linux
unspecified
low
Target Milestone: GA
: cfme-future
Assignee: Lucy Fu
QA Contact: Dmitry Misharov
URL:
Whiteboard: control:event
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-11 20:08 UTC by Tamer Embaby
Modified: 2017-03-21 09:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-27 13:40:42 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Tamer Embaby 2017-02-11 20:08:53 UTC
Description of problem:
I'm using CloudForms Management Engine and I was trying to create a Control Policy based on VM discovery. The problem is while creating "Control Policy" I cannot find "VM Discovery" event in the "VM Lifecycle" as explained by the Red Hat CloudForms 4.2 - Policies and Profiles Guide.

Version-Release number of selected component:
5.7.0.17.20161219135818_725f92f

How reproducible:
Create a control policy and try to assign an event for it, the "VM Lifecycle" group should contain "VM Discovery" as per the documentation. However there is no "VM Discovery" found in the whole page.

Expected results:
"VM Discovery" option under "VM Lifecycle"

Additional info:
N/A

Comment 2 Lucy Fu 2017-02-13 20:13:18 UTC
VM discovery event has been removed per BZ #1238371.

Seems vm_create should be used as your event in the policy.
Also our document should be updated accordingly.

Comment 3 Dmitry Misharov 2017-02-14 08:40:04 UTC
I've filled an appropriate bug https://bugzilla.redhat.com/show_bug.cgi?id=1421959

Comment 6 Tamer Embaby 2017-02-27 16:04:46 UTC
Dear Lucy,

Thank you for responding, you closed it as "Not a bug", just for my own records:
- The documentation says "VM Discovery" should be there, should I report this in a separate ticket to be corrected and remove "VM Discovery" option from Red Hat documentation?
- How can I base a Control event on "VM discovery" if this option is not present? What other ways to do that?

Thank you for properly closing the ticket and fixing my issue.

Tamer

Comment 7 Lucy Fu 2017-02-27 16:44:21 UTC
Hi Tamer,

- Removing "VM Discovery" from documentation has been resolved via BZ #1421959.
- Use vm_create for your policy.

Comment 8 Tamer Embaby 2017-02-28 14:00:32 UTC
Thank you Lucy and Dmitry.


Note You need to log in before you can comment on or make changes to this bug.