Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1421389 - Missing SmartState Analysis menu item
Summary: Missing SmartState Analysis menu item
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.7.0
Hardware: All
OS: Linux
low
low
Target Milestone: GA
: cfme-future
Assignee: Zita Nemeckova
QA Contact: Satyajit Bulage
URL:
Whiteboard: smartstate:openstack
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-11 22:54 UTC by Tamer Embaby
Modified: 2017-10-02 08:23 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-02 08:23:02 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Tamer Embaby 2017-02-11 22:54:48 UTC
Description of problem:

A missing menu item that is documented in CloudForms 4.2 while in reality it doesn't exist under "instances" in Cloud provider.

I checked it in Infrastructure provider under "Virtual Machines" and it's there. 


Version-Release number of selected component (if applicable):
5.7.0.17.20161219135818_725f92f

How reproducible:
Try to perform SSA on multiple instances from an OpenStack cloud provider.

Steps to Reproduce:
1. Compute -> Cloud -> Instances -> Instances by Provider
2. Choose provider of OpenStack type for example, click Configuration
3. There is no "Perform SmartState Analysis" menu item

Actual results:
No "Perform SmartState Analysis" menu item.

Expected results:
As per the documentation of CloudForms 4.2 Managing Providers, there should be a menu item that says "Perform SmartState Analysis" to perform SSA on multiple instances at once.

Additional info:
N/A

Comment 6 Dave Johnson 2017-02-23 17:33:11 UTC
Is the smartproxy role enabled per the documentation?

Comment 7 Tamer Embaby 2017-02-24 22:42:59 UTC
Dave,

Of course, smart proxy is enabled, I can perform smart proxy on the machine from:
Compute -> Cloud -> Instances by Provider -> Click the instance I want to perform SSA on and choose "Perform SmartState Analysis" from Configuration menu. This is for OpenStack cloud provider.

But if I go to:
Compute -> Cloud -> Instances by Provider -> select (check) multiple instances, then if I go to "Configuration" menu there is no "Perform SmartState Analysis" menu item as it supposed to be according to the 4.2 documentation which clearly says it should be there.

Thanks.

Comment 8 Tamer Embaby 2017-02-24 22:44:06 UTC
Correction:
I can perform smart "proxy" -> I can perform smart "state analysis".

Comment 9 Dave Johnson 2017-05-02 19:28:25 UTC
Satyajit, can you reproduce this?

Comment 10 Satyajit Bulage 2017-05-03 13:23:23 UTC
Hello Dave,

After following mentioned steps, I am able to see "Perform SmartState Analysis" in both the cases on latest 5.8.z.

Thanks,
Satyajit Bulage.

Comment 11 Zita Nemeckova 2017-10-02 08:23:02 UTC
I cannot reproduce on upstream/darga, upstream/euwe, upstream/fine or master.


Note You need to log in before you can comment on or make changes to this bug.