Bug 1421420 - Update VM 'Console->Advanced Parameters->Disable strict user checking' will initiate 'VM NUMA add' audit message
Summary: Update VM 'Console->Advanced Parameters->Disable strict user checking' will i...
Keywords:
Status: CLOSED DUPLICATE of bug 1291064
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core
Version: 4.1.0.4
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
: ---
Assignee: Nobody
QA Contact: meital avital
URL:
Whiteboard:
Depends On: 1291064
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-12 08:37 UTC by Artyom
Modified: 2017-03-01 11:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-01 11:32:54 UTC
oVirt Team: SLA


Attachments (Terms of Use)

Description Artyom 2017-02-12 08:37:38 UTC
Description of problem:
Update VM 'Console->Advanced Parameters->Disable strict user checking' option will initiate VM NUMA node audit message
2017-02-12 03:18:03,160-05 INFO  [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-22) [43c019b6-06b8-4c2f-bb2b-0639ebd17df9] Running command: Upd
ateVmCommand internal: false. Entities affected :  ID: 5df59ddd-a70a-405e-b528-f02bdcf0d3c9 Type: VMAction group EDIT_VM_PROPERTIES with role type USER 
2017-02-12 03:18:03,171-05 INFO  [org.ovirt.engine.core.bll.numa.vm.SetVmNumaNodesCommand] (default task-22) [6bf7ace6] Running command: SetVmNumaNodesCom
mand internal: true. 
2017-02-12 03:18:03,180-05 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-22) [6bf7ace6] EVENT_ID: NUMA_ADD_VM
_NUMA_NODE_SUCCESS(1,300), Correlation ID: 6bf7ace6, Call Stack: null, Custom Event ID: -1, Message: Add VM NUMA node successfully.

Version-Release number of selected component (if applicable):
rhevm-4.1.0.4-0.1.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Update VM 'Console->Advanced Parameters->Disable strict user checking' option
2.
3.

Actual results:
Engine will show the audit message about VM NUMA adding
'Add VM NUMA node successfully.'

Expected results:
This option does not relate to the VM NUMA nodes, so the engine must show only the message about VM update.

Additional info:
I checked the VM after update and looks it does not update any NUMA parameters, so looks it the only logging problem

Comment 1 Yaniv Kaul 2017-02-13 07:13:14 UTC
Dup of bug 1291064 ?

Comment 2 Artyom 2017-02-13 07:50:34 UTC
Do not think so, the https://bugzilla.redhat.com/show_bug.cgi?id=1291064 connect to the fact that the engine does not update automatically NUMA node memory and CPU in case if I update the VM memory or CPU.
In this bug, I talk about some small issue with audit messages(I believe it connect to the fact that we have 'strict' NUMA mode, so when I update the option 'Disable strict user checking', somewhere in the code we parse it as NUMA mode)

Comment 3 Doron Fediuck 2017-02-13 09:27:57 UTC
It may be just a side effect and not a bug.
We now verify NUMA updates on every edit VM, which outputs this message when a numa update indeed happens.

Martin, can you please verify?

Comment 4 Andrej Krejcir 2017-02-13 12:54:24 UTC
This is probably unwanted side effect of the fix for Bug 1291064.

Now, SetVmNumaNodes command is called every time a VM is edited, which is unnecessary.

Comment 5 Andrej Krejcir 2017-02-13 17:07:30 UTC
The fix will be part of Bug 1291064.

Comment 6 Doron Fediuck 2017-03-01 11:32:54 UTC

*** This bug has been marked as a duplicate of bug 1291064 ***


Note You need to log in before you can comment on or make changes to this bug.