Bug 1421433 - Any chance to get eigen3-nnls?
Summary: Any chance to get eigen3-nnls?
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: eigen3
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rich Mattes
QA Contact: Fedora Extras Quality Assurance
URL: https://sourceforge.net/p/proteowizar...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-12 10:08 UTC by Antonio T. (sagitter)
Modified: 2017-02-16 09:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-16 09:18:36 UTC
Type: Bug


Attachments (Terms of Use)

Description Antonio T. (sagitter) 2017-02-12 10:08:27 UTC
Description of problem:

'libpwiz' is searching for 'nnls.h' header file during its compiling. That file is provided by 'eigen3-nnls' (Non-Negative Least Squares implementation for Eigen3).

Is there any chance to implement 'eigen3-nnls' in 'eigen3'?

Version-Release number of selected component (if applicable):
libpwiz >= 3.0.10462-1

How reproducible:
Always.

Actual results:
libpwiz cannot be compiled.

Comment 1 Sandro Mani 2017-02-12 22:33:35 UTC
I think it would better be a separate package, since 
- It is not part of upstream eigen3
- The review is stalled since 2014: http://eigen.tuxfamily.org/bz/show_bug.cgi?id=655

Or perhaps even just bundle it, since it looks dead upstream...

Also, have you tested whether it is even compatible with the latest eigen-3.3.x, given that it included quite some changes?

Comment 2 Sandro Mani 2017-02-16 09:18:36 UTC
Marking WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.