Bug 1421440 - tripleo-ansible-inventory does not report ceph
Summary: tripleo-ansible-inventory does not report ceph
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M2
: 12.0 (Pike)
Assignee: Florian Fuchs
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-12 11:10 UTC by Amit Ugol
Modified: 2018-02-05 19:04 UTC (History)
12 users (show)

Fixed In Version: openstack-tripleo-validations-7.1.1-0.20170621111847.fb7346f.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-13 21:08:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 450233 0 None None None 2017-04-19 14:40:18 UTC
Red Hat Product Errata RHEA-2017:3462 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Amit Ugol 2017-02-12 11:10:42 UTC
Description of problem:
Ceph nodes are not reported when using tripleo-ansible-inventory --list
This worked well in previous rhos11 versions and as a tech preview in rhos10.

Version-Release number of selected component (if applicable):
openstack-tripleo-validations-5.3.1-0.20170125194508.6b928f1.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. deploy with ceph nodes (note that locally I am calling it 'ceph'
2. source stackrc
3. run tripleo-ansible-inventory --list

Actual results:
[stack@undercloud-0 ~]$ tripleo-ansible-inventory --list 2> /dev/null | tr "{}" "\n"

"overcloud": 
"children": ["controller", "compute"], "vars": 
"ansible_ssh_user": "heat-admin"

, "controller": ["192.168.24.12"], "undercloud": 
"hosts": ["localhost"], "vars": 
"overcloud_horizon_url": "http://10.0.0.105:80/dashboard", "overcloud_admin_password": "bBNw4aJwbkzh6Eqht9eXVF9CM", "ansible_connection": "local"

, "compute": ["192.168.24.17"]


Expected results:
"children" should have ceph.
ceph section needs to have ceph stuff.


Additional info:
Deployment command:
openstack overcloud deploy --debug \
--templates \
--libvirt-type kvm \
--ntp-server clock.redhat.com \
--control-scale 1 \
--control-flavor controller \--compute-scale 1 \
--compute-flavor compute \
--environment-file /usr/share/openstack-tripleo-heat-templates/environments/services/sahara.yaml \
--environment-file /usr/share/openstack-tripleo-heat-templates/environments/cinder-backup.yaml \
--ceph-storage-scale 1 \
--ceph-storage-flavor ceph \
-e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml \
-e /home/stack/virt/ceph.yaml \
-e /home/stack/virt/network/network-environment.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
-e /home/stack/virt/hostnames.yml \
-e /home/stack/virt/debug.yaml \
--log-file overcloud_deployment_23.log

Comment 4 Steven Hardy 2017-04-11 12:52:51 UTC
This is because we have hard-coded role references like here:

https://github.com/openstack/tripleo-validations/blob/master/scripts/tripleo-ansible-inventory#L141

self.fetch_stack_resources('Controller') etc

The fix is to retrieve the roles_data.yaml from the plan container, then iterate over all roles.

AFAICS this has never worked, so I'm not sure the "This worked well.." comment is accurate, unless something got lost in translation when we did this initial commit to tripleo-validations?

https://github.com/openstack/tripleo-validations/commit/f614ef744fc2949ea8911683662ae50896a8f398

Comment 6 Florian Fuchs 2017-05-11 13:25:21 UTC
Merged upstream for pike

Comment 7 Thierry Vignaud 2017-06-27 12:47:28 UTC
Can you add the gerrit id please so that we can check if we've the relevant change?
Thanks

Comment 10 Florian Fuchs 2017-09-05 11:22:42 UTC
(In reply to Thierry Vignaud from comment #7)
> Can you add the gerrit id please so that we can check if we've the relevant
> change?

Yes, the one attached to the ticket contains the relevant change:

  https://review.openstack.org/#/c/450233/

Comment 14 errata-xmlrpc 2017-12-13 21:08:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.