Bug 1421467 - RNG: Impossible to run more than 1 VM with /dev/hwrng source
Summary: RNG: Impossible to run more than 1 VM with /dev/hwrng source
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.1.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Michal Skrivanek
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-12 13:57 UTC by Nisim Simsolo
Modified: 2017-02-12 14:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-12 14:43:31 UTC
oVirt Team: Virt


Attachments (Terms of Use)
vdsm.log (89.30 KB, text/plain)
2017-02-12 14:12 UTC, Nisim Simsolo
no flags Details
vdsm.log (461.65 KB, application/x-xz)
2017-02-12 14:13 UTC, Nisim Simsolo
no flags Details
qemu log (47.15 KB, text/plain)
2017-02-12 14:15 UTC, Nisim Simsolo
no flags Details

Description Nisim Simsolo 2017-02-12 13:57:07 UTC
Description of problem:
Trying to run more than 1 VM with /dev/hwrng source failed with vdsm.log ERROR: 
- libvirtError: Requested operation is not valid: PCI device 0000:02:00.0 is in use by driver QEMU, domain 1_VFIO_f23_Intel

And qemu log ERRORL
ERROR:backends/rng-random.c:47:entropy_available: assertion failed: (len != -1)

Version-Release number of selected component (if applicable):
ovirt-engine-4.1.1-0.1.el7
libvirt-client-2.0.0-10.el7_3.4.x86_64
qemu-kvm-rhev-2.6.0-28.el7_3.5.x86_64
vdsm-4.19.5-1.el7ev.x86_64
sanlock-3.4.0-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Browse webadmin -> cluster tab -> edit cluster: Verify compatibility version is 4.1. check /dev/hwrng source checkbox.
2. Run VM with /dev/hwrng source enabled.
3. Try to run another VM with /dev/hwrng source enabled.

Actual results:
The second Vm is not going up.

Expected results:
More than one VM should be able to run with /dev/hwrng source.

Additional info:
qemu log attached (2017-02-09 15:54:35.886+0000)
and vdsm.log attached (2017-02-12 15:54:54,232)

Comment 1 Nisim Simsolo 2017-02-12 14:12:03 UTC
Created attachment 1249558 [details]
vdsm.log

Comment 2 Nisim Simsolo 2017-02-12 14:13:08 UTC
Created attachment 1249559 [details]
vdsm.log

Comment 3 Nisim Simsolo 2017-02-12 14:15:03 UTC
Created attachment 1249560 [details]
qemu log

Comment 4 Nisim Simsolo 2017-02-12 14:43:31 UTC
Closing as not a bug. although it looks in the logs like it's related to hwrng device, the issue was with same VFIO device attached to both VMs.


Note You need to log in before you can comment on or make changes to this bug.