Bug 142148 - Segmentation fault
Summary: Segmentation fault
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xsane   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-07 17:52 UTC by Daniel Malmgren
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 0.95-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 12:16:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Malmgren 2004-12-07 17:52:07 UTC
Description of problem:
After upgrading xsane to 0.95 I'm unable to start it any more.

Version-Release number of selected component (if applicable):
0.95-1

How reproducible:
100%

Steps to Reproduce:
1. Start xsane
2. I get a requester with license stuff
3. xsane segfaults
  
Additional info:
Backtrace follows:

(gdb) run
Starting program: /usr/bin/xsane

Program received signal SIGSEGV, Segmentation fault.
0x0806a532 in preview_create_preset_area_menu (p=0x82124e0,
selection=0) at xsane-preview.c:4104
4104        preset_area_item =
gtk_menu_item_new_with_label(preferences.preset_area[i]->name);
(gdb) bt
#0  0x0806a532 in preview_create_preset_area_menu (p=0x82124e0,
selection=0) at xsane-preview.c:4104
#1  0x080737eb in preview_new () at xsane-preview.c:4436
#2  0x080b4c49 in xsane_device_dialog () at xsane.c:7839
#3  0x080b6e67 in xsane_interface (argc=1, argv=0xbffff944) at
xsane.c:8492
#4  0x080b80a4 in main (argc=0, argv=0xbffff944) at xsane.c:8721

Comment 1 Tim Waugh 2004-12-07 18:49:20 UTC
Confirmed.

Comment 2 Michal Jaegermann 2004-12-07 23:09:09 UTC
Everything nicely starts and scans if one will rename an existing
~/.sane.  I did not try which of files in this directory is really
a culprit (they were two in ~/.sane/xsane and now I have three).
The reaction is indeed somewhat extreme. :-) 'strace' ends up with

--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

This detail that it started to ask me again about accepting
a license was a giveaway.

Comment 3 Daniel Malmgren 2004-12-08 09:26:47 UTC
Confirming Michals workaround. Removing ~/.sane/xsane/xsane.rc made
xsane work again (though of course all my settings were gone).

Comment 4 Tim Waugh 2004-12-08 09:33:25 UTC
It will ask about the license *anyway* when you upgrade versions.  I think this
is due to some settings moving into a different file.  I need to talk to Oliver
Rauch about it.

Comment 6 Tim Waugh 2004-12-08 12:16:21 UTC
Fixed in 0.95-2.


Note You need to log in before you can comment on or make changes to this bug.