Description of problem:
Rawhide version of python-jinja2 has moved forward 2.9.x but ansible package requires only jinj2 < 2.9. Thus failure of packages that "Requires: ansible" e.g. ansible-lint and ansible-inventory-grapher
Version-Release number of selected component (if applicable):
Steps to Reproduce:
1. update jinja2 version requirement from 2.9 to 2.10
current jinja2 requirement is < 2.9
update jinja2 version requirement from 2.9 to 2.10
What need to be changed is modify setup.py as
- install_requires=['paramiko', 'jinja2 < 2.9', "PyYAML", 'setuptools', 'pycrypto >= 2.6'],
+ install_requires=['paramiko', 'jinja2 >= 2.6, <2.10', "PyYAML", 'setuptools', 'pycrypto >= 2.6'],
or maybe just use the ansible-newer-jinja.patch
Yes, because python-jinja2 2.9.4 broke ansible templating.
My understanding is that 2.9.5 (now in rawhide) fixes the biggest part of this, but it's unclear if there's other patches we need to carry or wait until 2.2.2 is out.
Will consult with upstream on it...
*** Bug 1423235 has been marked as a duplicate of this bug. ***
Upstream says many of the issues are fixed with 2.9.5, but there is still at least:
So, workaround for now is to downgrade:
Sorry about this, hopefully things will be fixed soon.
ok. I pushed 22.214.171.124-rc1 to rawhide (which hopefully has things fixed and works with jinja2 1.9.x.
This should unblock other packages and get some more testing...