Bug 1421485 - bump the dependency version of jinja2
Summary: bump the dependency version of jinja2
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ansible
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1423235 (view as bug list)
Depends On:
Blocks: 1423220 1424571
TreeView+ depends on / blocked
 
Reported: 2017-02-12 16:44 UTC by Parag Nemade
Modified: 2017-02-22 18:25 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-22 18:25:17 UTC
Type: Bug


Attachments (Terms of Use)

Description Parag Nemade 2017-02-12 16:44:45 UTC
Description of problem:
Rawhide version of python-jinja2 has moved forward 2.9.x but ansible package requires only jinj2 < 2.9. Thus failure of packages that "Requires: ansible" e.g. ansible-lint and ansible-inventory-grapher

Version-Release number of selected component (if applicable):
ansible-2.2.1.0-2.fc26

How reproducible:
always

Steps to Reproduce:
1. update jinja2 version requirement from 2.9 to 2.10
2.
3.

Actual results:
current jinja2 requirement is < 2.9

Expected results:
update jinja2 version requirement from 2.9 to 2.10

Additional info:
What need to be changed is modify setup.py as

-      install_requires=['paramiko', 'jinja2 < 2.9', "PyYAML", 'setuptools', 'pycrypto >= 2.6'],
+      install_requires=['paramiko', 'jinja2 >= 2.6, <2.10', "PyYAML", 'setuptools', 'pycrypto >= 2.6'],

or maybe just use the ansible-newer-jinja.patch

Comment 1 Kevin Fenzi 2017-02-12 19:33:45 UTC
Yes, because python-jinja2 2.9.4 broke ansible templating. 

My understanding is that 2.9.5 (now in rawhide) fixes the biggest part of this, but it's unclear if there's other patches we need to carry or wait until 2.2.2 is out. 

Will consult with upstream on it...

Comment 2 Kevin Fenzi 2017-02-17 17:37:31 UTC
*** Bug 1423235 has been marked as a duplicate of this bug. ***

Comment 3 Kevin Fenzi 2017-02-17 17:41:39 UTC
Upstream says many of the issues are fixed with 2.9.5, but there is still at least: 

https://github.com/ansible/ansible/issues/20494

So, workaround for now is to downgrade: 

https://koji.fedoraproject.org/koji/buildinfo?buildID=830281

Sorry about this, hopefully things will be fixed soon.

Comment 4 Kevin Fenzi 2017-02-22 18:25:17 UTC
ok. I pushed 2.2.2.0-rc1 to rawhide (which hopefully has things fixed and works with jinja2 1.9.x. 

This should unblock other packages and get some more testing...


Note You need to log in before you can comment on or make changes to this bug.