Bug 1421502 - Arduino GUI fails to run arduino-builder (wrong path to executable)
Summary: Arduino GUI fails to run arduino-builder (wrong path to executable)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: arduino
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gianluca Sforna
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-12 19:54 UTC by Eric Smith
Modified: 2017-07-31 16:21 UTC (History)
5 users (show)

Fixed In Version: arduino-1.6.6-3.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-31 16:21:48 UTC
Type: Bug


Attachments (Terms of Use)
fix arduino-builder to work in Fedora with arduino-1.6.6 (5.23 KB, patch)
2017-04-07 08:24 UTC, Kirill Kolyshkin
no flags Details | Diff

Description Eric Smith 2017-02-12 19:54:29 UTC
Description of problem:

Attempting to compile a sketch in the Arduino IDE gives an error
"Cannot run program "/usr/share/arduino/arduino-builder"

Version-Release number of selected component (if applicable):
arduino-1.6.6-1.fc25.noarch

How reproducible:
100%

Steps to Reproduce:
1. Open Arduino IDE
2. Attempt to compile the default sketch (control-R, or menu Sketch item Verify/Compile)

Actual results:
arduino-builder is not found

Expected results:
arduino-builder should be run

Additional info:
This appears to be a result of the unbundling of arduino-builder; the arduino-builder RPM installs /usr/bin/arduino-builder rather than /usr/share/arduino/arduino-builder.

Comment 1 Gianluca Sforna 2017-02-13 11:56:44 UTC
Hi Eric, the same issue was promptly catched by another tester https://bodhi.fedoraproject.org/updates/arduino-1.6.6-1.fc25#comment-560753 (I assume you're not him) but I am still working on a fix since it appears more than a path fix is required to make it work properly.

Please keep testing (and give karma) to the proposed updates so we can keep Arduino fully updated in Fedora.

Comment 2 Fedora Admin XMLRPC Client 2017-02-26 00:17:51 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Kirill Kolyshkin 2017-04-07 01:34:12 UTC
I am seeing the same bug with the following rpms installed from fedora-updates-testing (F25/x86_64):

[kir@kir-tpad ~]$ rpm -qa ardui\*
arduino-builder-1.0.5-3.fc25.x86_64
arduino-doc-1.6.4-10.fc25.noarch
arduino-1.6.6-1.fc25.noarch
arduino-core-1.6.6-1.fc25.noarch

Comment 4 Kirill Kolyshkin 2017-04-07 04:31:12 UTC
(In reply to Gianluca Sforna from comment #1)
> but I am still working on a fix since it appears
> more than a path fix is required to make it work properly.

Indeed, creating the following symlink doesn't fix the issue

usr/share/arduino/arduino-builder -> /usr/bin/arduino-builder

but uncovers more problems, which I was able to fix with a few patches to arduino-builder.

Gianluca, are you interested in those patches?

Comment 5 Kirill Kolyshkin 2017-04-07 08:24:22 UTC
Created attachment 1269609 [details]
fix arduino-builder to work in Fedora with arduino-1.6.6

Comment 6 Fedora Update System 2017-07-21 22:09:37 UTC
arduino-builder-1.0.5-6.fc26 arduino-1.6.6-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-394c0f1880

Comment 7 Fedora Update System 2017-07-23 06:57:35 UTC
arduino-1.6.6-2.fc25, arduino-builder-1.0.5-6.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c33ec5464a

Comment 8 Fedora Update System 2017-07-23 09:59:43 UTC
arduino-1.6.6-3.fc26, arduino-builder-1.0.5-6.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-394c0f1880

Comment 9 Fedora Update System 2017-07-31 16:21:48 UTC
arduino-1.6.6-3.fc26, arduino-builder-1.0.5-6.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.