Bug 1421613 (CVE-2017-5953) - CVE-2017-5953 vim: Tree length values not validated properly when handling a spell file
Summary: CVE-2017-5953 vim: Tree length values not validated properly when handling a ...
Status: CLOSED WONTFIX
Alias: CVE-2017-5953
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=low,public=20170208,reported=2...
Keywords: Security
Depends On: 1421652
Blocks: 1421615
TreeView+ depends on / blocked
 
Reported: 2017-02-13 09:17 UTC by Andrej Nemec
Modified: 2019-06-08 21:48 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-02-23 07:47:46 UTC


Attachments (Terms of Use)

Description Andrej Nemec 2017-02-13 09:17:18 UTC
It was found that vim does not properly validate values for tree length when handling a spell file, which may result in an integer overflow at a memory allocation site and a resultant buffer overflow.

Upstream bug:

https://groups.google.com/forum/#!topic/vim_dev/t-3RSdEnrHY

Upstream patch:

https://github.com/vim/vim/commit/399c297aa93afe2c0a39e2a1b3f972aebba44c9d

Comment 1 Andrej Nemec 2017-02-13 11:09:57 UTC
Created vim tracking bugs for this issue:

Affects: fedora-all [bug 1421652]


Note You need to log in before you can comment on or make changes to this bug.