Bug 142162 - X can't display remote programs
X can't display remote programs
Status: CLOSED DUPLICATE of bug 137685
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-07 13:50 EST by Glenn W. Bach
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-31 15:37:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Glenn W. Bach 2004-12-07 13:50:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Whenever I try to run a program on another system and display it on
mine, I get X errors, like BadWindow, BadAtom, etc. Even things like
the redhat-config programs won't display. My system is FC3 and the
remote systems are RHEL3. For some reason, I can display an xterm, but
most other things give errors.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12.FC3.21

How reproducible:
Always

Steps to Reproduce:
1. Log into RHEL3 or similar
2. Run an X program like redhat-config-users
3. 
    

Actual Results:  For example:
The program 'redhat-config-users' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 39 error_code 3 request_code 25 minor_code 0)

kde programs, like kprinter, give a bunch of BadAtom and BadWindow
properties, but still eventually show up.


Expected Results:  The program would display correctly.

Additional info:
Comment 1 Sitsofe Wheeler 2004-12-08 12:10:39 EST
I think you might have come a cropper on the "ssh -X has changed to ssh -Y"
upstream change. You don't mention ssh though so I could be wildly off. If you
are using ssh, see bug 141894 for some more details.
Comment 2 Sitsofe Wheeler 2004-12-10 07:17:01 EST
Just to be sure -
Glenn, are you using ssh to connect to the remote machines?
Comment 3 Glenn W. Bach 2004-12-10 18:41:39 EST
This is an ssh issue. I just figured it out. It was just strange that X sort of
worked sometimes. The solution was to add ForwardX11Trusted in addition to
ForwardX11. I think this is a goofy set up on ssh's part. It should either work
or not, and if it doesn't work, it should tell me why, not just give BadAtom errors.

Sorry for troubling you about this.
Comment 4 Tomas Mraz 2005-01-31 15:36:48 EST

*** This bug has been marked as a duplicate of 137685 ***

Note You need to log in before you can comment on or make changes to this bug.