Bug 1421658 - systemd crashes when unit file is removed while service is executing ExecStartPre command
Summary: systemd crashes when unit file is removed while service is executing ExecStar...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: Radka Skvarilova
URL:
Whiteboard:
Depends On:
Blocks: 74systemd
TreeView+ depends on / blocked
 
Reported: 2017-02-13 11:38 UTC by Michal Sekletar
Modified: 2017-08-01 09:14 UTC (History)
3 users (show)

Fixed In Version: systemd-219-32.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:14:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2297 normal SHIPPED_LIVE systemd bug fix and enhancement update 2017-08-01 12:40:16 UTC

Description Michal Sekletar 2017-02-13 11:38:57 UTC
Description of problem:
$subject

Version-Release number of selected component (if applicable):
systemd-219-30.el7_3.6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Have following unit file,

$ cat /etc/systemd/system/crasher.service
[Service]
ExecStartPre=/bin/sleep 10
ExecStart=/bin/true

2. Reload systemd
$ systemctl daemon-reload

3. Start the service, remove unit file and reload systemd
$ systemctl --no-block start crasher.service && rm -f /etc/systemd/system/crasher.service && systemctl daemon-reload

4. Wait for 10 seconds

Actual results:
Feb 13 06:30:16 qeos-82.lab.eng.rdu2.redhat.com systemd[1]: Caught <ABRT>, dumped core as pid 1377.
Feb 13 06:30:16 qeos-82.lab.eng.rdu2.redhat.com systemd[1]: Freezing execution.

Above messages in journal, systemd is not responding to requests.

Expected results:
systemd can handle situation gracefully

Additional info:
upstream fix, 

https://github.com/systemd/systemd/commit/47fffb3530af3e3ad4048570611685635fde062e

Comment 1 Lukáš Nykrýn 2017-02-13 13:47:43 UTC
https://github.com/lnykryn/systemd-rhel/pull/92

Comment 3 Lukáš Nykrýn 2017-02-20 10:57:08 UTC
fix merged to upstream staging branch ->
                https://github.com/lnykryn/systemd-rhel/commit/a66f97acac8b99a49aac58adf6d652cad7e4be38
                -> post

Comment 6 errata-xmlrpc 2017-08-01 09:14:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2297


Note You need to log in before you can comment on or make changes to this bug.