Bug 142166 - pkgorder failure for x86_64 on i386
pkgorder failure for x86_64 on i386
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-07 14:40 EST by Matthew Kent
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 10:41:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Kent 2004-12-07 14:40:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040917 Firefox/0.9.3

Description of problem:
Trying to run pkgorder on my i386 kickstart server to produce a
working x86_64 kickstart with some custom rpms.

This issue has been raised before here
http://www.redhat.com/archives/fedora-list/2004-May/msg06831.html but no
solution was mentioned. And since I haven't a clue with python :) I'm at
a bit of a loss.

I would love to forgo moving my whole kickstart 'area' to another server.

Version-Release number of selected component (if applicable):
anaconda-runtime-10.1.0.2-1

How reproducible:
Always

Steps to Reproduce:
1. Run pkgorder /usr/kickstart/core3_64 x86_64 Fedora > pkgfile from a
i386 server on a x86_64 repository

Actual Results:  root@hal [/root]# cd /usr/kickstart/core3_64
root@hal [/usr/kickstart/core3_64]# export PYTHONPATH=/usr/lib/anaconda
root@hal [/usr/kickstart/core3_64]# export
PATH=$PATH:/usr/lib/anaconda-runtime
root@hal [/usr/kickstart/core3_64]# pkgorder /usr/kickstart/core3_64
x86_64 Fedora > pkgfile
Traceback (most recent call last):
  File "/usr/lib/anaconda-runtime/pkgorder", line 209, in ?
    pkgOrder.append(hdlist[package].nevra())
  File "/usr/lib/anaconda/hdrlist.py", line 423, in __getitem__
    raise KeyError, "No such package %s" %(item,)
KeyError: 'No such package kernel-smp'

Expected Results:  Created a pkgorder file to be used in genhdlist.

Additional info:
Comment 1 Jeremy Katz 2004-12-08 10:41:05 EST
Unfortunately, with the way we have to do ordering now, you really
have to use a machine of the same arch to generate trees.

Note You need to log in before you can comment on or make changes to this bug.