Bug 1421706 - [SDN][Cloud Networks] - undefined method - Advanced search filter
Summary: [SDN][Cloud Networks] - undefined method - Advanced search filter
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.8.0
Assignee: Hilda Stastna
QA Contact: Matouš Mojžíš
URL:
Whiteboard: ui:sdn:filter
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-13 13:33 UTC by Pavol Kotvan
Modified: 2019-08-06 20:04 UTC (History)
8 users (show)

Fixed In Version: 5.8.0.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-31 14:34:28 UTC
Category: Bug
Cloudforms Team: Unknown
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:1367 normal SHIPPED_LIVE Moderate: CFME 5.8.0 security, bug, and enhancement update 2017-05-31 18:16:03 UTC

Comment 3 Tzu-Mainn Chen 2017-02-22 21:10:57 UTC
Hilda, would this have been fixed as part of https://github.com/ManageIQ/manageiq-ui-classic/pull/142?  I tried reproducing it on master but couldn't.

Comment 4 Hilda Stastna 2017-02-23 13:14:51 UTC
Tzu-Mainn-Chen,

I was able to reproduce the bug on master (always),
but we have to correct steps to reproduce little bit (step 2).
For me, this is a bug, for sure.

Try this:
1. Navigate to Networks -> Networks -> Advanced search
2. Create this filter:

Field - Cloud Network: active
Check the checkbox "user will input the value".
Don't choose from the options true/false.
(It shouldn't be possible to have chosen one of true/false options and to have checkbox checked at the same time)

3. Click on 'Commit expression element changes' button
4. Click Apply button

Then I get the same error as mentioned here.
The error also occurs if you save the filter (clicking on "Save" button) after commiting and then click on "Apply" button or if you click on the filter from accordion (after saving it).

Comment 8 Hilda Stastna 2017-02-27 15:27:13 UTC
fixing https://github.com/ManageIQ/manageiq-ui-classic/pull/494

Comment 9 Matouš Mojžíš 2017-04-25 11:30:05 UTC
Verified in 5.8.0.11. Saving/applying this filter works and no exception is displayed.

Comment 11 errata-xmlrpc 2017-05-31 14:34:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2017:1367


Note You need to log in before you can comment on or make changes to this bug.