Bug 1421711 - yap-6.2.2-19.fc26 FTBFS: YAP OOOPS: tried to access illegal address on i686
Summary: yap-6.2.2-19.fc26 FTBFS: YAP OOOPS: tried to access illegal address on i686
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: yap
Version: 26
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL: https://sourceforge.net/p/yap/mailman...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-13 13:54 UTC by Petr Pisar
Modified: 2017-03-03 12:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-03 12:17:52 UTC
Type: Bug


Attachments (Terms of Use)

Description Petr Pisar 2017-02-13 13:54:51 UTC
yap-6.2.2-19.fc26 fails to build on i686 with GCC 7:

make[1]: Entering directory '/builddir/build/BUILD/yap-6.2.2/packages/clib'
mkdir -p /builddir/build/BUILDROOT/yap-6.2.2-19.fc26.i386/usr/lib/Yap
for f in unix.so random.so socket.so cgi.so memfile.so files.so mime.so crypt.so time.so readutil.so streaminfo.so process.so sha4pl.so uri.so; do \
	  /usr/bin/install -c $f /builddir/build/BUILDROOT/yap-6.2.2-19.fc26.i386/usr/lib/Yap; \
	done
mkdir -p /builddir/build/BUILDROOT/yap-6.2.2-19.fc26.i386/usr/share/Yap
for f in ./unix.pl ./random.pl ./socket.pl ./cgi.pl ./memfile.pl ./filesex.pl ./mime.pl ./crypt.pl ./time.pl ./streaminfo.pl ./process.pl ./prolog_server.pl ./sha.pl ./socket.pl ./uri.pl; do \
	  /usr/bin/install -c -m 644 $f /builddir/build/BUILDROOT/yap-6.2.2-19.fc26.i386/usr/share/Yap; \
	done
LD_LIBRARY_PATH=/builddir/build/BUILDROOT/yap-6.2.2-19.fc26.i386/usr/lib:/builddir/build/BUILDROOT/yap-6.2.2-19.fc26.i386/usr/lib/Yap: YAPSHAREDIR=/builddir/build/BUILDROOT/yap-6.2.2-19.fc26.i386/usr/share/Yap YAPLIBDIR=/builddir/build/BUILDROOT/yap-6.2.2-19.fc26.i386/usr/lib/Yap /builddir/build/BUILDROOT/yap-6.2.2-19.fc26.i386/usr/bin/yap /builddir/build/BUILDROOT/yap-6.2.2-19.fc26.i386/usr/lib/Yap/startup.yss -f none -g make -t halt
% Restoring file /builddir/build/BUILDROOT/yap-6.2.2-19.fc26.i386/usr/lib/Yap/startup.yss
YAP 6.2.2 (i686-linux): Mon Feb 13 13:46:48 UTC 2017
MYDDAS version MYDDAS-0.9.1
%
%
% YAP OOOPS: tried to access illegal address 0x2024448b!!!!.
%
%
1295KB of Code Space (0x10000000--0x10143db0)
%
% PC: prolog:$file_is_unchanged/3 at clause 1 
%   Continuation: prolog:$ensure_file_unchanged/3 at clause 1 
%    512KB of Global Stack (0x103ea000--0x1046a25c)
%    0KB of Local Stack (0x10515d00--0x10516000)
%    0KB of Trail (0x10516004--0x10516030)
%    Performed 0 garbage collections
% All Active Calls and
%         Goals With Alternatives Open  (Global In Use--Local In Use)
%
%  prolog:$ensure_file_unchanged/3 at clause 1 
%  prolog:$ensure_file_unchanged/3 at clause 1 
%  prolog:$start_lf/11 at clause 2 
%  prolog:$lf/14 at clause 7 
%  prolog:$load_files/3 at clause 1 
%         idb:$lf_loaded/0 (512KB--0KB)
%  prolog:make/0 at clause 1 
%  prolog:once/1 at clause 1 
%  prolog:$do_yes_no/2 at clause 2 
%  prolog:$yes_no/2 at clause 1 
%         prolog:$catch/3 (512KB--0KB)
%  prolog:$system_catch/4 at clause 1 
%  prolog:$startup_goals/0 at clause 2 
%  prolog:$init_system/0 at clause 1 
%  prolog:$live/0 at clause 1 
%  meta-call
   Exiting ....
make[1]: Leaving directory '/builddir/build/BUILD/yap-6.2.2/packages/clib'

This does not happen in Fedora 25.

Comment 1 Fedora End Of Life 2017-02-28 11:16:39 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 26 development cycle.
Changing version to '26'.

Comment 2 Fedora Admin XMLRPC Client 2017-03-03 12:07:48 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Petr Pisar 2017-03-03 12:17:52 UTC
This package was removed from Fedora ≥ 26.


Note You need to log in before you can comment on or make changes to this bug.