Bug 142172 - ETHTOOL_OPTS works in DL-360-G4 (tg3), but in DL-380-G4 (tg3) does not work.
ETHTOOL_OPTS works in DL-360-G4 (tg3), but in DL-380-G4 (tg3) does not work.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-07 15:30 EST by Mauricio Cavalcanti
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:11:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mauricio Cavalcanti 2004-12-07 15:30:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET 
CLR 1.1.4322)

Description of problem:
I have many DL-360-G4 using ETHTOOL_OPTS in ifcfg-eth0, forcing 100 
Mbps, full duplex and autoneg off, but when I put the same 
ETHTOOL_OPTS in DL-380-G4 (tg3), I have 100 Mbps, half duplex and 
autoneg off. It seems it´s not reading ETHTOOL_OPTS.

In DL-380-G4, when i run "ifcfg eth0 down", ethtool command shows me 
100Mbps... if NIC is down and "ifconfig" command don´t show me any 
about eth0 (only "lo"), how it "ethtool" command shows me 100Mbps and 
more? In DL-360-G4, it works fine.

I put ethtool comand in rc.local as workaround, and it´s working as I 
want (100 Mbps, full duplex and autoneg off).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.set ETHTOOL_OPTS in ifcfg-eth0 with speed 100 duplex full autoneg 
off;
2.reboot or network restart;
3.run "ethtool eth0"... the answer is "speed 100 duplex half autoneg 
off", not full duplex;
4.if I run or put "ethtool -s eth0 speed 100 duplex full autoneg off" 
in rc.local, it works fine.
    

Actual Results:  run "ethtool eth0" and the answer is "speed 100 
duplex half autoneg off", not full duplex, even when eth0 is down !

Expected Results:  ETHTOOL_OPTS must work if I put in ifcfg-eth0 and 
ethtool cannot answer "speed 100 duplex half autoneg off" if NIC eth0 
is down.

Additional info:
Comment 2 Bill Nottingham 2005-02-18 16:44:09 EST
Are you using the exact same network config in both cases?
Comment 3 Mauricio Cavalcanti 2005-02-21 06:21:14 EST
Yes.
Comment 5 Prarit Bhargava 2007-09-12 13:55:54 EDT
Mauricio, is this still an issue?

P.
Comment 6 RHEL Product and Program Management 2007-10-19 15:11:58 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.