Bug 1421835 - dnf list command broken
dnf list command broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
: Regression, Triaged
: 1422568 1424713 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-02-13 14:36 EST by darrell pfeifer
Modified: 2017-02-20 10:17 EST (History)
9 users (show)

See Also:
Fixed In Version: dnf-2.1.0-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-16 06:32:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description darrell pfeifer 2017-02-13 14:36:36 EST
Description of problem:

# dnf list updates
ArgumentError: argument --obsoletes: conflicting option string: --obsoletes

# dnf list dnf
ArgumentError: argument --obsoletes: conflicting option string: --obsoletes


Version-Release number of selected component (if applicable):

# rpm -q dnf
dnf-2.0.1-2.fc26.noarch

Additional info:

dnf clean all
dnf update works
Comment 1 Jaroslav Mracek 2017-02-14 05:20:38 EST
There is PR https://github.com/rpm-software-management/dnf/pull/736 that should fix it
Comment 2 Igor Gnatenko 2017-02-15 10:34:58 EST
*** Bug 1422568 has been marked as a duplicate of this bug. ***
Comment 3 niemand 2017-02-16 16:01:41 EST
Ahoj, Jaroslav,

I have the same problem with # rpm -q dnf => dnf-2.0.1-2.fc26.noarch

I checked the link you provided, and recompiled python scripts (did git clone ...), was able to fix with this broken rawhide upgrade.

Please, let us know the release date of fixed version (dnf-2.1.0-1.fc26).

Also, adding myself to list of watchers. ;-)

_nobody_
Comment 4 Jaroslav Mracek 2017-02-17 02:56:20 EST
dnf-2.1.0-1.fc26 is in koji and waits for successful compose of rawhide. Hope that it will be available soon, but I cannot speedup it. But it is possible to directly download rpms from koji: https://koji.fedoraproject.org/koji/buildinfo?buildID=859607

Hope that it helps

Jaroslav
Comment 5 zoran.stojsavljevic 2017-02-17 05:20:26 EST
Jaroslav, you are failing?!

Does not help! :-(

[root@localhost Downloads]# rpm -i dnf-2.1.0-1.fc26.noarch.rpm
error: Failed dependencies:
	python3-dnf = 2.1.0-1.fc26 is needed by dnf-2.1.0-1.fc26.noarch
[root@localhost Downloads]# yum install python3-dnf
Last metadata expiration check: 1:30:58 ago on Fri Feb 17 09:43:31 2017 CET.
Package python3-dnf-2.0.1-2.fc26.noarch is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!
[root@localhost Downloads]# 

(could you, please, correctly identify ALL dependencies here)?!

QA is not helping here, not at all...

Thank you,
_nobody_
Comment 6 Igor Gnatenko 2017-02-17 05:27:33 EST
You need more than just dnf, but also subpackages like python3-dnf from the same build.
Comment 7 zoran.stojsavljevic 2017-02-17 05:41:06 EST
Privet Igor,

Ne srabotalo. Ja sdelal vse, daze bolee... No eto... Vasa (Fedora rawhide maintainers) osibka. Pozaluista, bud6te bolee vnimatel6ni, mozno poprisit6?! ;-)
_______

Transcript from CLI follows:

[root@localhost Downloads]# rpm -i dnf-conf-2.1.0-1.fc26.noarch.rpm
	file /usr/share/man/man5/dnf.conf.5.gz from install of dnf-conf-2.1.0-1.fc26.noarch conflicts with file from package dnf-conf-2.0.1-2.fc26.noarch
[root@localhost Downloads]# dnf remove dnf-conf-2.0.1-2.fc26.noarch
Error: package python3-dnf-2.0.1-2.fc26.noarch requires dnf-conf = 2.0.1-2.fc26, but none of the providers can be installed
  - package dnf-2.0.1-2.fc26.noarch requires python3-dnf = 2.0.1-2.fc26, but none of the providers can be installed
  - conflicting requests
  - problem with installed package dnf-2.0.1-2.fc26.noarch
[root@localhost Downloads]# yum remove dnf-2.0.1-2.fc26.noarch
Error: The operation would result in removing the following protected packages: dnf
[root@localhost Downloads]# yum upgrade  
Last metadata expiration check: 0:00:00 ago on Fri Feb 17 11:32:35 2017 CET.
Dependencies resolved.
Nothing to do.
Complete!
[root@localhost Downloads]# yum clean all
38 files removed
[root@localhost Downloads]# yum upgrade
Fedora - Rawhide - Developmental packages for the next Fedora releas 5.6 MB/s |  52 MB     00:09    
google-chrome-unstable                                                49 kB/s | 3.8 kB     00:00    
google-chrome                                                         45 kB/s | 3.8 kB     00:00    
RPM Fusion for Fedora Rawhide - Free                                 949 kB/s | 532 kB     00:00    
RPM Fusion for Fedora Rawhide - Nonfree                              182 kB/s | 157 kB     00:00    
Last metadata expiration check: 0:00:00 ago on Fri Feb 17 11:33:34 2017 CET.
Dependencies resolved.
Nothing to do.
Complete!
[root@localhost Downloads]# yum remove dnf-conf-2.0.1-2.fc26.noarch
Error: package python3-dnf-2.0.1-2.fc26.noarch requires dnf-conf = 2.0.1-2.fc26, but none of the providers can be installed
  - package dnf-2.0.1-2.fc26.noarch requires python3-dnf = 2.0.1-2.fc26, but none of the providers can be installed
  - conflicting requests
  - problem with installed package dnf-2.0.1-2.fc26.noarch
[root@localhost Downloads]# dnf install python3-dnf
Last metadata expiration check: 0:00:40 ago on Fri Feb 17 11:33:34 2017 CET.
Package python3-dnf-2.0.1-2.fc26.noarch is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!
[root@localhost Downloads]# 

Spasibo za otvet!
_nobody_ (_nikto_)
Comment 8 Igor Gnatenko 2017-02-18 11:44:18 EST
*** Bug 1424713 has been marked as a duplicate of this bug. ***
Comment 9 Jaroslav Mracek 2017-02-19 02:43:04 EST
To upgrade to dnf-2.1.0-1 please do as follows:
1a. Upgrade all subpackages of dnf:
```sudo dnf upgrade https://kojipkgs.fedoraproject.org//packages/dnf/2.1.0/1.fc26/noarch/dnf-2.1.0-1.fc26.noarch.rpm https://kojipkgs.fedoraproject.org//packages/dnf/2.1.0/1.fc26/noarch/dnf-automatic-2.1.0-1.fc26.noarch.rpm https://kojipkgs.fedoraproject.org//packages/dnf/2.1.0/1.fc26/noarch/dnf-conf-2.1.0-1.fc26.noarch.rpm https://kojipkgs.fedoraproject.org//packages/dnf/2.1.0/1.fc26/noarch/dnf-yum-2.1.0-1.fc26.noarch.rpm https://kojipkgs.fedoraproject.org//packages/dnf/2.1.0/1.fc26/noarch/python2-dnf-2.1.0-1.fc26.noarch.rpm https://kojipkgs.fedoraproject.org//packages/dnf/2.1.0/1.fc26/noarch/python3-dnf-2.1.0-1.fc26.noarch.rpm```

1b. or create empty directory and download all packages:
```wget https://kojipkgs.fedoraproject.org//packages/dnf/2.1.0/1.fc26/noarch/dnf-2.1.0-1.fc26.noarch.rpm https://kojipkgs.fedoraproject.org//packages/dnf/2.1.0/1.fc26/noarch/dnf-automatic-2.1.0-1.fc26.noarch.rpm https://kojipkgs.fedoraproject.org//packages/dnf/2.1.0/1.fc26/noarch/dnf-conf-2.1.0-1.fc26.noarch.rpm https://kojipkgs.fedoraproject.org//packages/dnf/2.1.0/1.fc26/noarch/dnf-yum-2.1.0-1.fc26.noarch.rpm https://kojipkgs.fedoraproject.org//packages/dnf/2.1.0/1.fc26/noarch/python2-dnf-2.1.0-1.fc26.noarch.rpm https://kojipkgs.fedoraproject.org//packages/dnf/2.1.0/1.fc26/noarch/python3-dnf-2.1.0-1.fc26.noarch.rpm```
Then:
```sudo dnf upgrade *.rpm```

Hope that it helps

Jaroslav
Comment 10 niemand 2017-02-20 10:14:01 EST
> 1b. or create empty directory and download all packages:

Helped. Indeed. :-)

Thank you, Jaroslav!

_nobody_
Comment 11 Bill Gianopoulos 2017-02-20 10:17:49 EST
Or just use the command "yum-deprecated list" instead!

Note You need to log in before you can comment on or make changes to this bug.