Bug 1422 - cannot compile Tk400.202
cannot compile Tk400.202
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-04 14:17 EST by awest
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-28 21:57:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description awest 1999-03-04 14:17:45 EST
perl Makefile.PL of the Tk400.202 module
seg faults just after TK::Pixmap
Comment 1 awest 1999-03-26 15:22:59 EST
perl 5.005_02 from CPAN compiles Tk400.202, unlike
the perl shipped w\ RH5.2
Comment 2 Preston Brown 1999-03-30 16:46:59 EST
have you tried the errata release of the perl for RHL 5.2?
Comment 3 David Lawrence 1999-05-31 18:14:59 EDT
I was unable to replicate theis problem compiling Tk402.4004 obtained
from cpan.org on a stock 5.2 system. The 5.2 system also has the
latest perl for 5.2 errata available at ftp://updates.redhat.com so
you may wnt to get that also.
Comment 4 awest 1999-06-01 13:04:59 EDT
My problem is compiling Tk400.202, not Tk402.4004. Last time
I looked, Tk402.4004 was not supposed to be a production release.
The fact that PERL seg faults points to a problem with perl, not with
Tk::Perl. I originally observed this problem, using
perl-5.004m7-1.i386.rpm from yuor updates site; As a matter of
fact, I've never tried the perl from the cdrom; I upgraded
immediately after I did the install.
Comment 5 David Lawrence 1999-06-01 15:14:59 EDT
Okay, I obtained the version of Tk that the user requested. The
Makefile is successfully constructed on a 4.2 and 6.0 system but seg
faults on a 5.2 machine using the latest perl update for 5.2 from our
updates site. There is an obvious incompatibility between the version
of perl and the version Tk being used. This is being assigned to a
developer so that a solution may be obtained.
Comment 6 Cristian Gafton 1999-07-28 21:57:59 EDT
Tk400.202 exposes a real problem in the perl package; hoever, that
version of perl is not being maintained anymore and there are other
versions of perl that can be used with this module.

We can not provide an update for 5.2 at this time because there is no
binary compatible version of perl available that we can upgrade to. I
recommend using the src.rpm that is included in 6.0 and doing a "rpm
--rebuild" on it.

Note You need to log in before you can comment on or make changes to this bug.