Bug 142218 - Hald Segfaults at startup
Hald Segfaults at startup
Status: CLOSED DUPLICATE of bug 142183
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-08 02:42 EST by Mike Voxx
Modified: 2013-03-05 22:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Hald Log (108.03 KB, text/plain)
2004-12-08 02:45 EST, Mike Voxx
no flags Details

  None (edit)
Description Mike Voxx 2004-12-08 02:42:07 EST
Description of problem:
Hald segfaults with the following message when running /usr/sbin/hald
--daemon=no --verbose=yes 

*****************************************************

02:30:48.398 [I] linux/osspec.c:793: handling /sys/class/net/eth0 net
02:30:48.415 [E] linux/net_class_device.c:137: SIOCGMIIREG on eth0
failed: Bad address

02:30:48.415 [E] linux/net_class_device.c:137: SIOCGMIIREG on eth0
failed: Bad address

02:30:48.415 [W] linux/net_class_device.c:257: Error reading link info
02:30:48.415 [E] linux/net_class_device.c:137: SIOCGMIIREG on eth0
failed: Bad address

02:30:48.416 [W] linux/net_class_device.c:193: Error reading rate info
Segmentation fault


****************************************************
Version-Release number of selected component (if applicable):
hal-0.4.2-1.FC3

How reproducible:
Don't Know.. depeding on hardware?
  
Actual results:
Hald Segfaults

Expected results:
Hald should run

Additional info:
ide-drives.fdi was patched as per previous bug report #141771 (missing
/ in XML)
Comment 1 Mike Voxx 2004-12-08 02:45:29 EST
Created attachment 108089 [details]
Hald Log

this is the log hald generates when run with --verbrose=yes flag
Comment 2 Mike Voxx 2004-12-08 02:47:23 EST
eth0 is a "Marvell Technology GRoup LTD. Yukon Gigabit Ethernet
10/100/1000Base-T Adapter" 

it is my only network card and it is currently connected to the
internet.... 


Comment 3 David Zeuthen 2004-12-09 11:01:08 EST

*** This bug has been marked as a duplicate of 142183 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:07:37 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.