Bug 1422291 - picard-1.4.2 is available
Summary: picard-1.4.2 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: picard
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alex Lancaster
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-15 00:17 UTC by Upstream Release Monitoring
Modified: 2018-12-14 20:41 UTC (History)
10 users (show)

Fixed In Version: picard-2.0.4-2.fc28
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-18 14:10:46 UTC
Type: ---


Attachments (Terms of Use)
[patch] Update to 1.4 (#1422291) (1.06 KB, patch)
2017-02-15 00:17 UTC, Upstream Release Monitoring
no flags Details | Diff
[patch] Update to 1.4.1 (#1422291) (1.06 KB, patch)
2017-04-02 00:17 UTC, Upstream Release Monitoring
no flags Details | Diff
patch picard's spec file (4.48 KB, patch)
2017-04-10 09:03 UTC, pzeppegno
no flags Details | Diff
[patch] Update to 1.4.2 (#1422291) (1.06 KB, patch)
2017-05-09 00:18 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2017-02-15 00:17:49 UTC
Latest upstream release: 1.4
Current version/release in rawhide: 1.3.2-6.fc25
URL: http://picard.musicbrainz.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/3633/

Comment 1 Upstream Release Monitoring 2017-02-15 00:17:56 UTC
Created attachment 1250415 [details]
[patch] Update to 1.4 (#1422291)

Comment 2 Upstream Release Monitoring 2017-02-15 00:23:22 UTC
hotness's scratch build of picard-1.4-1.el7.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=17869843

Comment 3 Dario Castellarin 2017-02-17 02:02:23 UTC
Bump to this, after 2 years Picard really needed a refresh.

Comment 4 Dario Castellarin 2017-03-03 21:18:20 UTC
Ping?

Comment 5 Upstream Release Monitoring 2017-04-02 00:17:22 UTC
Latest upstream release: 1.4.1
Current version/release in rawhide: 1.3.2-7.fc26
URL: http://picard.musicbrainz.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/3633/

Comment 6 Upstream Release Monitoring 2017-04-02 00:17:31 UTC
Created attachment 1268174 [details]
[patch] Update to 1.4.1 (#1422291)

Comment 7 Upstream Release Monitoring 2017-04-02 00:26:18 UTC
hotness's scratch build of picard-1.4.1-1.el7.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=18724262

Comment 8 pzeppegno 2017-04-08 22:06:12 UTC
I went ahead and created my own rpm. The failure is caused by the removal of all plugins from the .tar.gz
I simply commented out any reference to them.
They also added a high res .svg version of the icon. Fixing the package takes 3 minutes, if we don't take into account the removal of the plugins.

Comment 9 pzeppegno 2017-04-10 09:03:04 UTC
Created attachment 1270428 [details]
patch picard's spec file

Just removed anything related to plugins.
They have been remove from the tar file upstream and should probably be managed differently now. In the meantime this got me going.

Comment 10 Upstream Release Monitoring 2017-05-09 00:18:12 UTC
Latest upstream release: 1.4.2
Current version/release in rawhide: 1.3.2-7.fc26
URL: http://picard.musicbrainz.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/3633/

Comment 11 Upstream Release Monitoring 2017-05-09 00:18:20 UTC
Created attachment 1277184 [details]
[patch] Update to 1.4.2 (#1422291)

Comment 12 Upstream Release Monitoring 2017-05-09 00:23:57 UTC
hotness's scratch build of picard-1.4.2-1.el7.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=19464619

Comment 13 Pedro Albuquerque Santos 2017-09-16 16:31:04 UTC
Any progress on getting building Picard 1.4.2 for Fedora?

Comment 14 pzeppegno 2018-04-11 07:18:50 UTC
Any progress on getting building Picard 1.4.2 for Fedora?

Comment 15 Tim Jackson 2018-07-02 21:49:48 UTC
I've made a clean update to 1.4.2 and submitted a pull request: https://src.fedoraproject.org/rpms/picard/pull-request/1

Could one of the maintainers consider merging it?

Here's a clean scratch build:
https://koji.fedoraproject.org/koji/taskinfo?taskID=27995658

Comment 16 Fedora Update System 2018-07-03 10:27:24 UTC
picard-1.4.2-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-0ebddddee1

Comment 17 Fedora Update System 2018-07-03 10:27:35 UTC
picard-1.4.2-3.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-70f56ad184

Comment 18 Fedora Update System 2018-07-03 10:27:42 UTC
picard-1.4.2-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-d79b4b71bb

Comment 19 Fedora Update System 2018-07-04 15:37:04 UTC
picard-1.4.2-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-d79b4b71bb

Comment 20 Fedora Update System 2018-07-04 16:21:59 UTC
picard-1.4.2-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-0ebddddee1

Comment 21 Fedora Update System 2018-07-04 18:20:05 UTC
picard-1.4.2-3.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-70f56ad184

Comment 22 Fedora Update System 2018-10-16 22:06:01 UTC
picard-2.0.4-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-935dab2253

Comment 23 Fedora Update System 2018-10-18 05:16:30 UTC
picard-2.0.4-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-935dab2253

Comment 24 Fedora Update System 2018-10-18 14:08:01 UTC
picard-2.0.4-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-03970cd203

Comment 25 Gerald Cox 2018-10-18 14:10:46 UTC
Should have been closed when 1.4.2 update was completed.

Comment 26 Fedora Update System 2018-10-19 16:52:41 UTC
picard-2.0.4-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-03970cd203

Comment 27 Fedora Update System 2018-10-27 16:15:12 UTC
picard-2.0.4-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 28 Randy Barlow 2018-12-11 17:04:09 UTC
A Fedora update associated with this bug has been pushed to the stable repository.

Comment 29 Randy Barlow 2018-12-14 20:41:19 UTC
A Fedora update associated with this bug has been pushed to the stable repository.


Note You need to log in before you can comment on or make changes to this bug.